aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-05-03 16:27:20 +0800
committersobomax <sobomax@FreeBSD.org>2001-05-03 16:27:20 +0800
commit48c18a6929419f9b71e186fc52354547bea96b60 (patch)
tree579dede200757bafa894597393fdd29c712c6e0d /databases
parent795a5bcd5183e6aaaa445c0b49690603727ce8e5 (diff)
downloadfreebsd-ports-gnome-48c18a6929419f9b71e186fc52354547bea96b60.tar.gz
freebsd-ports-gnome-48c18a6929419f9b71e186fc52354547bea96b60.tar.zst
freebsd-ports-gnome-48c18a6929419f9b71e186fc52354547bea96b60.zip
Unbreak with python2.1.
Diffstat (limited to 'databases')
-rw-r--r--databases/py-MySQL/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index bd3957a46c59..07f8c04f9971 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -16,7 +16,12 @@ MAINTAINER= dr@domix.de
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
USE_PYTHON= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} != "python2.1"
ALL_TARGET= MySQLmodule.so
+.endif
pre-configure:
${CP} ${FILESDIR}/Setup ${WRKSRC}/Setup
@@ -34,4 +39,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>