aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-07-18 04:11:56 +0800
committerpi <pi@FreeBSD.org>2015-07-18 04:11:56 +0800
commit491469813795ccb5960d82a147dc77a5dbd3d4ad (patch)
tree7dc908304e9762ccc21ec14f6c304fadeebc3152 /databases
parentdae27a81936ce7753b0fa9df6496f27941850926 (diff)
downloadfreebsd-ports-gnome-491469813795ccb5960d82a147dc77a5dbd3d4ad.tar.gz
freebsd-ports-gnome-491469813795ccb5960d82a147dc77a5dbd3d4ad.tar.zst
freebsd-ports-gnome-491469813795ccb5960d82a147dc77a5dbd3d4ad.zip
New port: databases/levigo
levigo is a Go wrapper for LevelDB. The API has been godoc'ed and is available on the web. Questions answered at golang-nuts@googlegroups.com. WWW: https://github.com/jmhodges/levigo PR: 194986 Submitted by: cheffo@freebsd-bg.org
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/levigo/Makefile42
-rw-r--r--databases/levigo/distinfo2
-rw-r--r--databases/levigo/pkg-descr5
-rw-r--r--databases/levigo/pkg-plist16
5 files changed, 66 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cbe14468347c..a3e691cc4b8a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -130,6 +130,7 @@
SUBDIR += leo_center
SUBDIR += leofs
SUBDIR += leveldb
+ SUBDIR += levigo
SUBDIR += libdbi
SUBDIR += libdbi-drivers
SUBDIR += libdrizzle
diff --git a/databases/levigo/Makefile b/databases/levigo/Makefile
new file mode 100644
index 000000000000..d3e5dac0836b
--- /dev/null
+++ b/databases/levigo/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= levigo
+PORTVERSION= 20150216
+CATEGORIES= databases
+
+MAINTAINER= cheffo@freebsd-bg.org
+COMMENT= Levigo is a Go wrapper for LevelDB
+
+LICENSE= MIT
+
+BUILD_DEPENDS= go:${PORTSDIR}/lang/go
+LIB_DEPENDS= libleveldb.so:${PORTSDIR}/databases/leveldb
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USES= compiler
+
+USE_GITHUB= yes
+GH_ACCOUNT= jmhodges
+GH_PROJECT= levigo
+GH_TAGNAME= 1ddad808d4
+
+BROKEN_FreeBSD_8= Build has leftover /readelf.core, PR 194986
+
+.include <bsd.port.pre.mk>
+
+# Build fails on FreeBSD10+ if value of "CC" is not set to "clang"
+# (checked by configure)
+
+.if ${COMPILER_TYPE} == clang
+CC= clang
+.else
+USE_GCC= yes
+.endif
+
+CONFIGURE_ENV+= CC=${CC} \
+ CXX=${CXX} \
+GO_ENV+= ${CONFIGURE_ENV}
+
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/levigo/distinfo b/databases/levigo/distinfo
new file mode 100644
index 000000000000..29e182804012
--- /dev/null
+++ b/databases/levigo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jmhodges-levigo-20150216-1ddad808d4_GH0.tar.gz) = 0f5df795cb4ce7ad692bd70296343fb5bbbe1e67ca32b0e235cf0b7a2bc32959
+SIZE (jmhodges-levigo-20150216-1ddad808d4_GH0.tar.gz) = 12837
diff --git a/databases/levigo/pkg-descr b/databases/levigo/pkg-descr
new file mode 100644
index 000000000000..ffb2822c262b
--- /dev/null
+++ b/databases/levigo/pkg-descr
@@ -0,0 +1,5 @@
+levigo is a Go wrapper for LevelDB.
+The API has been godoc'ed and is available on the web.
+Questions answered at golang-nuts@googlegroups.com.
+
+WWW: https://github.com/jmhodges/levigo
diff --git a/databases/levigo/pkg-plist b/databases/levigo/pkg-plist
new file mode 100644
index 000000000000..6859d9428c1a
--- /dev/null
+++ b/databases/levigo/pkg-plist
@@ -0,0 +1,16 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/batch.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/cache.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/comparator.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/conv.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/db.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/doc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/env.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/comparator_example.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/filterpolicy.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/iterator.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/leveldb_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/options.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/version.go