aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-12-17 16:50:54 +0800
committeraz <az@FreeBSD.org>2012-12-17 16:50:54 +0800
commit49e28401be2d98d1382041192cd9492d7afd8a88 (patch)
treeeb176d06cd2dcf4e86e08a8011388d5168f72270 /databases
parentf3db6f0c287e81fa77d8bebf2f3da548e133cb1f (diff)
downloadfreebsd-ports-gnome-49e28401be2d98d1382041192cd9492d7afd8a88.tar.gz
freebsd-ports-gnome-49e28401be2d98d1382041192cd9492d7afd8a88.tar.zst
freebsd-ports-gnome-49e28401be2d98d1382041192cd9492d7afd8a88.zip
Cleanup supporting perl version 5.8 and 5.10,
lang/perl5.8 and lang/5.10 will be removed from ports tree soon.
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Class-DBI-Lite/Makefile8
-rw-r--r--databases/p5-DBD-CSV/Makefile8
-rw-r--r--databases/p5-DBD-ODBC/Makefile4
-rw-r--r--databases/p5-DBIx-Class-DynamicDefault/Makefile9
-rw-r--r--databases/p5-DBIx-Class-QueryProfiler/Makefile10
-rw-r--r--databases/p5-DBIx-Class-Schema-PopulateMore/Makefile7
-rw-r--r--databases/p5-DBIx-Sunny/Makefile5
-rw-r--r--databases/p5-SQLite-Work/Makefile8
8 files changed, 5 insertions, 54 deletions
diff --git a/databases/p5-Class-DBI-Lite/Makefile b/databases/p5-Class-DBI-Lite/Makefile
index 2b208e640486..898a25fae26f 100644
--- a/databases/p5-Class-DBI-Lite/Makefile
+++ b/databases/p5-Class-DBI-Lite/Makefile
@@ -42,10 +42,4 @@ MAN3= Class::DBI::Lite.3 \
Class::DBI::Lite::TableInfo.3 \
Class::DBI::Lite::Tutorial.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.77:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-CSV/Makefile b/databases/p5-DBD-CSV/Makefile
index f01e2878fba5..04568c49fca6 100644
--- a/databases/p5-DBD-CSV/Makefile
+++ b/databases/p5-DBD-CSV/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= Bundle::DBD::CSV.3 \
DBD::CSV.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.90:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-ODBC/Makefile b/databases/p5-DBD-ODBC/Makefile
index f9f166e90cd5..8f83e743b4be 100644
--- a/databases/p5-DBD-ODBC/Makefile
+++ b/databases/p5-DBD-ODBC/Makefile
@@ -50,10 +50,6 @@ MYODBC= unixodbc
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.90:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/my $$myodbc/ s|q{}|"${MYODBC}"|' ${WRKSRC}/Makefile.PL
diff --git a/databases/p5-DBIx-Class-DynamicDefault/Makefile b/databases/p5-DBIx-Class-DynamicDefault/Makefile
index 0c13971baf11..afe4667f3721 100644
--- a/databases/p5-DBIx-Class-DynamicDefault/Makefile
+++ b/databases/p5-DBIx-Class-DynamicDefault/Makefile
@@ -23,11 +23,4 @@ PERL_CONFIGURE= yes
MAN3= DBIx::Class::DynamicDefault.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-QueryProfiler/Makefile b/databases/p5-DBIx-Class-QueryProfiler/Makefile
index f7965212df84..a373d9fe1744 100644
--- a/databases/p5-DBIx-Class-QueryProfiler/Makefile
+++ b/databases/p5-DBIx-Class-QueryProfiler/Makefile
@@ -26,12 +26,4 @@ PERL_CONFIGURE= yes
MAN3= DBIx::Class::QueryProfiler.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-Schema-PopulateMore/Makefile b/databases/p5-DBIx-Class-Schema-PopulateMore/Makefile
index ab8fa6cd1fee..fcc1d00f0a64 100644
--- a/databases/p5-DBIx-Class-Schema-PopulateMore/Makefile
+++ b/databases/p5-DBIx-Class-Schema-PopulateMore/Makefile
@@ -54,13 +54,6 @@ MAN3= DBIx::Class::Schema::PopulateMore.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Module-Pluggable>=3.9:${PORTSDIR}/devel/p5-Module-Pluggable \
- p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-Module-Pluggable>=3.9:${PORTSDIR}/devel/p5-Module-Pluggable \
- p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
.if ${PERL_LEVEL} < 501400
TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
.endif
diff --git a/databases/p5-DBIx-Sunny/Makefile b/databases/p5-DBIx-Sunny/Makefile
index 9e4eb5e7b9f2..5b3bb62ceae8 100644
--- a/databases/p5-DBIx-Sunny/Makefile
+++ b/databases/p5-DBIx-Sunny/Makefile
@@ -34,11 +34,6 @@ MAN3= DBIx::Sunny.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
.if ${PERL_LEVEL} < 501400
TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
.endif
diff --git a/databases/p5-SQLite-Work/Makefile b/databases/p5-SQLite-Work/Makefile
index 8024a9b1615c..4a6e08328b39 100644
--- a/databases/p5-SQLite-Work/Makefile
+++ b/databases/p5-SQLite-Work/Makefile
@@ -35,10 +35,4 @@ MAN1= sqlw_mail.1 \
post-patch:
${CHMOD} u+w ${WRKSRC}/Makefile.PL
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500807
-RUN_DEPENDS+= p5-CGI.pm>=3.10:${PORTSDIR}/www/p5-CGI.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>