aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-08 07:04:40 +0800
committermiwi <miwi@FreeBSD.org>2009-01-08 07:04:40 +0800
commit581bc79492a1344765dbcd410ab3d5472937429a (patch)
treebc98e31961b722ef65a38245145077e956b58ad5 /databases
parentdcc767be4adc97be4d8d3d979e0ce7e9cf457740 (diff)
downloadfreebsd-ports-gnome-581bc79492a1344765dbcd410ab3d5472937429a.tar.gz
freebsd-ports-gnome-581bc79492a1344765dbcd410ab3d5472937429a.tar.zst
freebsd-ports-gnome-581bc79492a1344765dbcd410ab3d5472937429a.zip
PQueue is a package providing low-level PQ protocol classes for
interacting with a PostgreSQL database. It supports version 3.0 of the protocol--the current primary version of protocol. The package also provides a basic protocol transaction class. This class keeps the state of the protocol in an interrupt safe manner, and validates the integrity of the communication as messages are received. In general, you probably will never use this package directly, unless you are writing a driver. WWW: http://python.projects.postgresql.org/ PR: ports/130252 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-pg_pqueue/Makefile29
-rw-r--r--databases/py-pg_pqueue/distinfo3
-rw-r--r--databases/py-pg_pqueue/pkg-descr12
-rw-r--r--databases/py-pg_pqueue/pkg-plist3
5 files changed, 48 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 821a4bac1056..c9fcf8400507 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -504,6 +504,7 @@
SUBDIR += py-mssql
SUBDIR += py-oops
SUBDIR += py-pg8000
+ SUBDIR += py-pg_pqueue
SUBDIR += py-psycopg
SUBDIR += py-psycopg2
SUBDIR += py-pyPgSQL
diff --git a/databases/py-pg_pqueue/Makefile b/databases/py-pg_pqueue/Makefile
new file mode 100644
index 000000000000..0bb23737256e
--- /dev/null
+++ b/databases/py-pg_pqueue/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: py-pg_pqueue
+# Date created: 07 Jan 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pg_pqueue
+PORTVERSION= 1.0.2
+CATEGORIES= databases python
+MASTER_SITES= http://python.projects.postgresql.org/files/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= PostgreSQL PQ Protocol Modules
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.pre.mk>
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/changes.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/py-pg_pqueue/distinfo b/databases/py-pg_pqueue/distinfo
new file mode 100644
index 000000000000..95889f87f91a
--- /dev/null
+++ b/databases/py-pg_pqueue/distinfo
@@ -0,0 +1,3 @@
+MD5 (pg_pqueue-1.0.2.tar.gz) = ca88e615a52182165a9a29395dfc5388
+SHA256 (pg_pqueue-1.0.2.tar.gz) = 45b94cfa616f3e241a1fc791b6f9b6db5bd848d79d6599cb30064882d3829d0b
+SIZE (pg_pqueue-1.0.2.tar.gz) = 16861
diff --git a/databases/py-pg_pqueue/pkg-descr b/databases/py-pg_pqueue/pkg-descr
new file mode 100644
index 000000000000..732995058c7a
--- /dev/null
+++ b/databases/py-pg_pqueue/pkg-descr
@@ -0,0 +1,12 @@
+PQueue is a package providing low-level PQ protocol classes for
+interacting with a PostgreSQL database. It supports version 3.0
+of the protocol--the current primary version of protocol. The
+package also provides a basic protocol transaction class. This
+class keeps the state of the protocol in an interrupt safe manner,
+and validates the integrity of the communication as messages are
+received.
+
+In general, you probably will never use this package directly,
+unless you are writing a driver.
+
+WWW: http://python.projects.postgresql.org/
diff --git a/databases/py-pg_pqueue/pkg-plist b/databases/py-pg_pqueue/pkg-plist
new file mode 100644
index 000000000000..e87ae8099233
--- /dev/null
+++ b/databases/py-pg_pqueue/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/changes.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%