aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-02-21 23:13:15 +0800
committerpawel <pawel@FreeBSD.org>2015-02-21 23:13:15 +0800
commit845ea581b33a66c78a9468508e1ccaf8c9963ecf (patch)
tree0c426cec9db745464168ded0da267851a528ee01 /databases
parent70e36e901ad8a92b0c58c8379c975cd4fb91bbc3 (diff)
downloadfreebsd-ports-gnome-845ea581b33a66c78a9468508e1ccaf8c9963ecf.tar.gz
freebsd-ports-gnome-845ea581b33a66c78a9468508e1ccaf8c9963ecf.tar.zst
freebsd-ports-gnome-845ea581b33a66c78a9468508e1ccaf8c9963ecf.zip
- Update to version 5.3.4 [1]
- Mark ignored for versions 51 and 55 of mysql [1] - Move things to proper places in Makefile - Remove PLIST_SUB, no subs needed - Define DOCS option, port uses PORTDOCS - Switch to PLIST_FILES, port installs only 3 files - Remove Author tag from pkg-descr file PR: 197348 [1] Submitted by: timp87@gmail.com [1] Approved by: maintainer timeout
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql-connector-odbc/Makefile25
-rw-r--r--databases/mysql-connector-odbc/distinfo4
-rw-r--r--databases/mysql-connector-odbc/files/patch-driver__execute.c32
-rw-r--r--databases/mysql-connector-odbc/pkg-descr1
-rw-r--r--databases/mysql-connector-odbc/pkg-plist2
5 files changed, 35 insertions, 29 deletions
diff --git a/databases/mysql-connector-odbc/Makefile b/databases/mysql-connector-odbc/Makefile
index 7b67490dfaae..41830be2ac38 100644
--- a/databases/mysql-connector-odbc/Makefile
+++ b/databases/mysql-connector-odbc/Makefile
@@ -2,28 +2,37 @@
# $FreeBSD$
PORTNAME= mysql-connector-odbc
-PORTVERSION= 5.1.9
+PORTVERSION= 5.3.4
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
-MASTER_SITE_SUBDIR= Connector-ODBC/5.1
+MASTER_SITE_SUBDIR= Connector-ODBC/5.3
PKGNAMESUFFIX= -${DRIVER_MANAGER}-mysql${MYSQL_VER}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= sergey@network-asp.biz
COMMENT= ODBC driver for MySQL${MYSQL_VER} / ${DRIVER_MANAGER}
+BUILD_DEPENDS= unixODBC>=2.2.14_1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
+
USE_LDCONFIG= yes
USE_MYSQL= yes
-DEFAULT_MYSQL_VER= 51
USES= cmake
-PLIST_SUB= VER=${PORTVERSION}
+IGNORE_WITH_MYSQL= 55 51
+
+CMAKE_ARGS= -DWITH_UNIXODBC=1
+LDFLAGS+= -L${LOCALBASE}/lib
+
+DRIVER_MANAGER= unixodbc
PORTDOCS= ChangeLog INSTALL \
README README.debug COPYING Licenses_for_Third-Party_Components.txt
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-BUILD_DEPENDS= unixODBC>=2.2.14_1:${PORTSDIR}/databases/unixODBC
-CMAKE_ARGS += -DWITH_UNIXODBC=1
-DRIVER_MANAGER= unixodbc
+PLIST_FILES= bin/myodbc-installer \
+ lib/libmyodbc5a.so \
+ lib/libmyodbc5w.so
+
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/databases/mysql-connector-odbc/distinfo b/databases/mysql-connector-odbc/distinfo
index 90eaedd9ce3b..8431c8f260ad 100644
--- a/databases/mysql-connector-odbc/distinfo
+++ b/databases/mysql-connector-odbc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mysql-connector-odbc-5.1.9.tar.gz) = d14a0d5ca0f0bc4fc4bbd8609c4e7fde56c70d8b3ae56eb2c3687ce794990ee9
-SIZE (mysql-connector-odbc-5.1.9.tar.gz) = 542281
+SHA256 (mysql-connector-odbc-5.3.4-src.tar.gz) = a5f7a490f2958f2768d18b8a57f71909f9699a8619c82776b3ad1c02b8abce0d
+SIZE (mysql-connector-odbc-5.3.4-src.tar.gz) = 667340
diff --git a/databases/mysql-connector-odbc/files/patch-driver__execute.c b/databases/mysql-connector-odbc/files/patch-driver__execute.c
index f191b08db140..474cd526abbd 100644
--- a/databases/mysql-connector-odbc/files/patch-driver__execute.c
+++ b/databases/mysql-connector-odbc/files/patch-driver__execute.c
@@ -1,22 +1,22 @@
---- driver/execute.c.orig 2011-10-04 23:19:00.000000000 +0300
-+++ driver/execute.c 2011-10-15 12:07:45.000000000 +0300
-@@ -424,11 +424,19 @@
- data= buff;
- break;
- case SQL_C_SBIGINT:
+--- driver/execute.c.orig 2014-11-05 14:41:16.000000000 +0300
++++ driver/execute.c 2014-11-05 14:44:10.000000000 +0300
+@@ -563,11 +563,19 @@
+ *res= buff;
+ break;
+ case SQL_C_SBIGINT:
+#ifdef MARIADB_BASE_VERSION
-+ length= longlong2str(*((longlong*) data),buff, -10, 1) - buff;
++ *length= longlong2str(*((longlong*) *res), buff, -10, 1) - buff;
+#else
- length= longlong2str(*((longlong*) data),buff, -10) - buff;
+ *length= longlong2str(*((longlong*) *res), buff, -10) - buff;
+#endif
- data= buff;
- break;
- case SQL_C_UBIGINT:
+ *res= buff;
+ break;
+ case SQL_C_UBIGINT:
+#ifdef MARIADB_BASE_VERSION
-+ length= longlong2str(*((ulonglong*) data),buff, 10, 1) - buff;
++ *length= longlong2str(*((ulonglong*) *res), buff, 10, 1) - buff;
+#else
- length= longlong2str(*((ulonglong*) data),buff, 10) - buff;
+ *length= longlong2str(*((ulonglong*) *res), buff, 10) - buff;
+#endif
- data= buff;
- break;
- case SQL_C_FLOAT:
+ *res= buff;
+ break;
+ case SQL_C_FLOAT:
diff --git a/databases/mysql-connector-odbc/pkg-descr b/databases/mysql-connector-odbc/pkg-descr
index 43bb7c929332..89c9baf1615c 100644
--- a/databases/mysql-connector-odbc/pkg-descr
+++ b/databases/mysql-connector-odbc/pkg-descr
@@ -1,4 +1,3 @@
MySQL Connector ODBC is an ODBC driver for interfacing to MySQL databases.
-Author: Erik H. Bakke
WWW: http://www.mysql.com/
diff --git a/databases/mysql-connector-odbc/pkg-plist b/databases/mysql-connector-odbc/pkg-plist
deleted file mode 100644
index d3c6cbae5e6f..000000000000
--- a/databases/mysql-connector-odbc/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/myodbc-installer
-lib/libmyodbc5.so