aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-09-09 11:26:37 +0800
committerwen <wen@FreeBSD.org>2011-09-09 11:26:37 +0800
commit9b37b3e3f4d6d5701b23464bcf233bef83ad47f4 (patch)
tree464725f9b8388b502f36f0c5c2a7bc71773d2392 /databases
parent2ce117f53b06d7d075911d7eea9a19ebe4bc2f83 (diff)
downloadfreebsd-ports-gnome-9b37b3e3f4d6d5701b23464bcf233bef83ad47f4.tar.gz
freebsd-ports-gnome-9b37b3e3f4d6d5701b23464bcf233bef83ad47f4.tar.zst
freebsd-ports-gnome-9b37b3e3f4d6d5701b23464bcf233bef83ad47f4.zip
- Use databases/py-sqlite3 instead of databases/py-pysqlite2x
PR: ports/160059 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/py-sqlobject/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index 7ed2c8d00437..3d67872a0862 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlobject
PORTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ COMMENT= A python object for manipulation with SQL table row
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}formencode>=1.2.2:${PORTSDIR}/www/py-formencode
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PYTHON= yes
+USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= SQLObject
PYDISTUTILS_NOEGGINFO= yes
@@ -45,7 +46,7 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py
.endif
.if defined(WITH_SQLITE)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite20
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
.if defined(WITH_MSSQL)