aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:00 +0800
commita8888c3d4b6d2a4ff1225d13f5eef48e124f9b1d (patch)
treedcb4c7fd434312b8802f7eca362f429c604051cb /databases
parentee2e7ac0daaac4e16b924cefc768b3bdcd7436c7 (diff)
downloadfreebsd-ports-gnome-a8888c3d4b6d2a4ff1225d13f5eef48e124f9b1d.tar.gz
freebsd-ports-gnome-a8888c3d4b6d2a4ff1225d13f5eef48e124f9b1d.tar.zst
freebsd-ports-gnome-a8888c3d4b6d2a4ff1225d13f5eef48e124f9b1d.zip
Use WANT_PGSQL instead of hard-coded RUN_DEPENDS
Note that postgresql-client was already brought in via USES=pgsql. Therefore the equivalent WANT_PGSQL is "lib server". Approved by: portmgr (blanket)
Diffstat (limited to 'databases')
-rw-r--r--databases/postgis23/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/databases/postgis23/Makefile b/databases/postgis23/Makefile
index 0031ce245713..51441dbb0b5c 100644
--- a/databases/postgis23/Makefile
+++ b/databases/postgis23/Makefile
@@ -16,8 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libproj.so:graphics/proj \
libgeos.so:graphics/geos \
libjson-c.so:devel/json-c
-RUN_DEPENDS= postmaster:databases/postgresql${PGSQL_VER_NODOT}-server
-
CONFLICTS= postgis20-2.0.* postgis-2.1.* postgis-22*
USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
@@ -29,6 +27,7 @@ SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_PERL5= build
+WANT_PGSQL= lib server
OPTIONS_DEFINE= LOADERGUI RASTER TOPOLOGY SFCGAL ADDRSTD
OPTIONS_DEFAULT= TOPOLOGY ADDRSTD