aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-07-04 23:17:23 +0800
committermarino <marino@FreeBSD.org>2015-07-04 23:17:23 +0800
commitab2f717e7dc8602456429700c17d234e17773078 (patch)
treefd81af5fdafa1040a9d258f9cbe8067044c4cdc1 /databases
parentb28a8220d8d8f89a7e6493364dea2699abb18968 (diff)
downloadfreebsd-ports-gnome-ab2f717e7dc8602456429700c17d234e17773078.tar.gz
freebsd-ports-gnome-ab2f717e7dc8602456429700c17d234e17773078.tar.zst
freebsd-ports-gnome-ab2f717e7dc8602456429700c17d234e17773078.zip
databases/rocksdb: Unbreak on DragonFly
For the third time, disable Werror on this port. For this latest version, that wasn't the only problem with regard to DragonFly -- the endian configuration code was wrong and required a patch to fix.
Diffstat (limited to 'databases')
-rw-r--r--databases/rocksdb/Makefile1
-rw-r--r--databases/rocksdb/files/patch-port_port__posix.h17
2 files changed, 18 insertions, 0 deletions
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index d09397bc5c5f..37e274a36340 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -21,6 +21,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_CXXSTD= c++11
USE_LDCONFIG= yes
USES= compiler:c++11-lib gmake
+MAKE_ARGS= DISABLE_WARNING_AS_ERROR=1
GH_ACCOUNT= facebook
USE_GITHUB= yes
diff --git a/databases/rocksdb/files/patch-port_port__posix.h b/databases/rocksdb/files/patch-port_port__posix.h
new file mode 100644
index 000000000000..368f9579c3db
--- /dev/null
+++ b/databases/rocksdb/files/patch-port_port__posix.h
@@ -0,0 +1,17 @@
+--- port/port_posix.h.orig 2015-06-11 22:49:11 UTC
++++ port/port_posix.h
+@@ -25,12 +25,11 @@
+ #else
+ #define PLATFORM_IS_LITTLE_ENDIAN false
+ #endif
+-#elif defined(OS_FREEBSD)
++#elif defined(OS_FREEBSD) || defined(OS_DRAGONFLYBSD)
+ #include <sys/endian.h>
+ #include <sys/types.h>
+ #define PLATFORM_IS_LITTLE_ENDIAN (_BYTE_ORDER == _LITTLE_ENDIAN)
+-#elif defined(OS_OPENBSD) || defined(OS_NETBSD) ||\
+- defined(OS_DRAGONFLYBSD) || defined(OS_ANDROID)
++#elif defined(OS_OPENBSD) || defined(OS_NETBSD) || defined(OS_ANDROID)
+ #include <sys/types.h>
+ #include <sys/endian.h>
+ #else