aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
committerrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
commitabe85598b76e65884f63f5d35b14a7a5837c77ee (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /databases
parenta6ebb885ab3952f319e4a2e650eba1580d82a26e (diff)
downloadfreebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.gz
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.zst
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Diffstat (limited to 'databases')
-rw-r--r--databases/arangodb32/Makefile1
-rw-r--r--databases/arangodb33/Makefile1
-rw-r--r--databases/clickhouse/Makefile7
-rw-r--r--databases/db5/Makefile3
-rw-r--r--databases/db6/Makefile4
-rw-r--r--databases/memcached/Makefile1
-rw-r--r--databases/mongodb36/Makefile1
-rw-r--r--databases/mysql-connector-c++/Makefile10
8 files changed, 2 insertions, 26 deletions
diff --git a/databases/arangodb32/Makefile b/databases/arangodb32/Makefile
index 26121b1f640e..39fd410d3278 100644
--- a/databases/arangodb32/Makefile
+++ b/databases/arangodb32/Makefile
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only builds on amd64"
-BROKEN_FreeBSD_10= libc++ is too old
USES= gmake ssl cmake:outsource,noninja python:2.7 compiler
USE_GITHUB= yes
diff --git a/databases/arangodb33/Makefile b/databases/arangodb33/Makefile
index c392c15afbfe..5dc0e6923efe 100644
--- a/databases/arangodb33/Makefile
+++ b/databases/arangodb33/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only builds on amd64: https://github.com/arangodb/arangodb/issues/2334"
-BROKEN_FreeBSD_10= libc++ is too old
CONFLICTS_INSTALL= arangodb32
CONFLICTS_BUILD= v8
diff --git a/databases/clickhouse/Makefile b/databases/clickhouse/Makefile
index c588824a2dbd..7c8fb8f620bd 100644
--- a/databases/clickhouse/Makefile
+++ b/databases/clickhouse/Makefile
@@ -13,7 +13,6 @@ COMMENT= ClickHouse is a column-oriented database management system
LICENSE= APACHE20
-BROKEN_FreeBSD_10= Builds but does not work
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only supported on amd64"
@@ -81,12 +80,6 @@ SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101513
-BUILD_DEPENDS+= clang50:devel/llvm50
-CC= clang50
-CXX= clang++50
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib/clickhouse|/var/db/clickhouse|;s|/var/log/clickhouse-server|/var/log/clickhouse|;s|/etc/clickhouse-server|${PREFIX}/etc/clickhouse-server|' ${WRKSRC}/dbms/programs/server/config.xml
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 1ebcc15dd841..7a55628f815b 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -74,11 +74,8 @@ DOCS_INSTALL_TARGET= install_docs
# db5 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
# and also bug#205001
CONFIGURE_ARGS+= --enable-posixmutexes
-. if ${OSVERSION} > 1100100
-# ^ leave that as ">" it really is greater than but NOT equal
# force POSIX mutexes - the OS supports PTHREAD_PROCESS_SHARED
CONFIGURE_ARGS+= --with-mutex=POSIX/pthreads
-. endif
.endif
post-patch:
diff --git a/databases/db6/Makefile b/databases/db6/Makefile
index 41b133b6a431..2c419c1a28ca 100644
--- a/databases/db6/Makefile
+++ b/databases/db6/Makefile
@@ -67,11 +67,7 @@ DOCS_INSTALL_TARGET= install_docs
.include <bsd.port.options.mk>
.if ${ARCH} == aarch64
-. if ${OSVERSION} > 1100100
CONFIGURE_ARGS+= --with-mutex=POSIX/pthreads
-. else
-CONFIGURE_ARGS+= --enable-posixmutexes
-. endif
.endif
post-patch:
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index 5e050444171f..95a0be453781 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -40,7 +40,6 @@ OPTIONS_DEFAULT= SASL DTRACE
OPTIONS_EXCLUDE+= DTRACE
.endif
-OPTIONS_EXCLUDE_FreeBSD_10+= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
diff --git a/databases/mongodb36/Makefile b/databases/mongodb36/Makefile
index bb74bbd8dbd2..6cf37d345c70 100644
--- a/databases/mongodb36/Makefile
+++ b/databases/mongodb36/Makefile
@@ -20,7 +20,6 @@ LICENSE_COMB= multi
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "Only supported on amd64 (i386 deprecated in v3)"
-BROKEN_FreeBSD_10= libc++ is too old
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>=2.4.4:devel/py-cheetah@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typing>=3.6.2:devel/py-typing@${PY_FLAVOR} \
diff --git a/databases/mysql-connector-c++/Makefile b/databases/mysql-connector-c++/Makefile
index 9e1ca96aed17..f07b287c57be 100644
--- a/databases/mysql-connector-c++/Makefile
+++ b/databases/mysql-connector-c++/Makefile
@@ -17,19 +17,13 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
USES= cmake:outsource compiler:c++11-lang mysql ssl
USE_LDCONFIG= yes
-CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}"
+CMAKE_ARGS= -DDOC_DESTINATION="${DOCSDIR}" -DCMAKE_ENABLE_C++11=ON
PLIST_SUB= PORTVERSION=${PORTVERSION}
PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100000
-CMAKE_ARGS+=-DCMAKE_ENABLE_C++11=ON
-.endif
-
post-install:
@${RM} ${STAGEDIR}${DOCSDIR}/INSTALL \
${STAGEDIR}${DOCSDIR}/COPYING
@@ -67,4 +61,4 @@ do-test:
test/unit/classes/statement )
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>