aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-08 20:01:23 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-08 20:01:23 +0800
commitbc450dcb1bb6875ec91ea2ca0dd2a1c69ef3ee24 (patch)
treed77e34a15ba26fd80c77c45887c09a6dc09dca1c /databases
parentdccb1ef571c67e8cb1b04d3b082ec55ff8891775 (diff)
downloadfreebsd-ports-gnome-bc450dcb1bb6875ec91ea2ca0dd2a1c69ef3ee24.tar.gz
freebsd-ports-gnome-bc450dcb1bb6875ec91ea2ca0dd2a1c69ef3ee24.tar.zst
freebsd-ports-gnome-bc450dcb1bb6875ec91ea2ca0dd2a1c69ef3ee24.zip
add p5-DBIx-Recordset
Perl module for abstraction and simplification of database access PR: 26958 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Recordset/Makefile26
-rw-r--r--databases/p5-DBIx-Recordset/distinfo1
-rw-r--r--databases/p5-DBIx-Recordset/files/patch-Makefile.PL29
-rw-r--r--databases/p5-DBIx-Recordset/pkg-comment1
-rw-r--r--databases/p5-DBIx-Recordset/pkg-descr8
-rw-r--r--databases/p5-DBIx-Recordset/pkg-plist11
7 files changed, 77 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9d7137175828..65a4a80be62a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -43,6 +43,7 @@
SUBDIR += p5-DBD-Pg
SUBDIR += p5-DBD-XBase
SUBDIR += p5-DBI
+ SUBDIR += p5-DBIx-Recordset
SUBDIR += p5-DBZ_File
SUBDIR += p5-GDBM
SUBDIR += p5-MLDBM
diff --git a/databases/p5-DBIx-Recordset/Makefile b/databases/p5-DBIx-Recordset/Makefile
new file mode 100644
index 000000000000..440270d72c7e
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: DBIx::Recordset
+# Date created: 29 Apr 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Recordset
+PORTVERSION= 0.23
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBIx::Database.3 DBIx::Intrors.3 DBIx::Recordset::DBSeq.3 \
+ DBIx::Recordset::FileSeq.3 DBIx::Recordset.3 DBIx::Compat.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Recordset/distinfo b/databases/p5-DBIx-Recordset/distinfo
new file mode 100644
index 000000000000..d490deb65295
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/distinfo
@@ -0,0 +1 @@
+MD5 (DBIx-Recordset-0.23.tar.gz) = 64cafcc42278264592322d958a5d4600
diff --git a/databases/p5-DBIx-Recordset/files/patch-Makefile.PL b/databases/p5-DBIx-Recordset/files/patch-Makefile.PL
new file mode 100644
index 000000000000..d961ee2939e5
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/files/patch-Makefile.PL
@@ -0,0 +1,29 @@
+*** Makefile.PL.orig Sun Apr 29 19:51:53 2001
+--- Makefile.PL Sun Apr 29 19:52:04 2001
+***************
+*** 8,13 ****
+--- 8,14 ----
+
+ use ExtUtils::MakeMaker;
+
++ =item
+ # Ignore the following DBD Drivers
+
+ %ignore = ('ExampleP' => 1,
+***************
+*** 183,189 ****
+
+ close FH ;
+ }
+!
+
+ WriteMakefile
+ (
+--- 184,190 ----
+
+ close FH ;
+ }
+! =cut
+
+ WriteMakefile
+ (
diff --git a/databases/p5-DBIx-Recordset/pkg-comment b/databases/p5-DBIx-Recordset/pkg-comment
new file mode 100644
index 000000000000..f50cc106a18e
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/pkg-comment
@@ -0,0 +1 @@
+Perl module for abstraction and simplification of database access
diff --git a/databases/p5-DBIx-Recordset/pkg-descr b/databases/p5-DBIx-Recordset/pkg-descr
new file mode 100644
index 000000000000..56c9b6435334
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/pkg-descr
@@ -0,0 +1,8 @@
+DBIx::Recordset is a perl module for abstraction and simplification of
+database access.
+
+The goal is to make standard database access (select/insert/update/delete)
+easier to handle and independend of the underlying DBMS. Special attention is
+made on web applications to make it possible to handle the state-less access
+and to process the posted data of formfields, but DBIx::Recordset is not
+limited to web applications.
diff --git a/databases/p5-DBIx-Recordset/pkg-plist b/databases/p5-DBIx-Recordset/pkg-plist
new file mode 100644
index 000000000000..dbb9070bfef0
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIx/Recordset/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Compat.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Database.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Intrors.pod
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Recordset.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Recordset/DBSeq.pm
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Recordset/FileSeq.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/DBIx/Recordset
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIx/Recordset
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DBIx 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true