aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2005-09-21 00:19:06 +0800
committermich <mich@FreeBSD.org>2005-09-21 00:19:06 +0800
commitc154a3ea4172d3764d080873cec2e75681c4fb5c (patch)
tree6fa97f9a5104741682d19eee57db800fef0b7720 /databases
parent8f3d24e12439bdd290c13fc15a6944d1a6d6c232 (diff)
downloadfreebsd-ports-gnome-c154a3ea4172d3764d080873cec2e75681c4fb5c.tar.gz
freebsd-ports-gnome-c154a3ea4172d3764d080873cec2e75681c4fb5c.tar.zst
freebsd-ports-gnome-c154a3ea4172d3764d080873cec2e75681c4fb5c.zip
New port.
Ksqlanalyzer is a MSSQL database client for KDE.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ksqlanalyzer/Makefile25
-rw-r--r--databases/ksqlanalyzer/distinfo2
-rw-r--r--databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_config.h15
-rw-r--r--databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_tds.h15
-rw-r--r--databases/ksqlanalyzer/pkg-descr13
-rw-r--r--databases/ksqlanalyzer/pkg-plist13
7 files changed, 84 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 5a8aee18d123..445b5b378640 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -75,6 +75,7 @@
SUBDIR += kbibtex
SUBDIR += kinterbasdb
SUBDIR += knoda
+ SUBDIR += ksqlanalyzer
SUBDIR += ksqlshell
SUBDIR += libdbi
SUBDIR += libdbi-drivers
diff --git a/databases/ksqlanalyzer/Makefile b/databases/ksqlanalyzer/Makefile
new file mode 100644
index 000000000000..e896d10287eb
--- /dev/null
+++ b/databases/ksqlanalyzer/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ksqlanalyzer
+# Date created: Tue Sep 20 11:38:46 CEST 2005
+# Whom: Michael L. Hostbaek <mich@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ksqlanalyzer
+PORTVERSION= 0.2.2
+CATEGORIES= databases kde
+MASTER_SITES= http://www.kpage.de/download/
+
+MAINTAINER= mich@FreeBSD.org
+COMMENT= MSSQL database client for KDE
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/databases/ksqlanalyzer/distinfo b/databases/ksqlanalyzer/distinfo
new file mode 100644
index 000000000000..c58f4bbaa0ab
--- /dev/null
+++ b/databases/ksqlanalyzer/distinfo
@@ -0,0 +1,2 @@
+MD5 (ksqlanalyzer-0.2.2.tar.gz) = 0854116fa29d2413794bfdd76c011594
+SIZE (ksqlanalyzer-0.2.2.tar.gz) = 883954
diff --git a/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_config.h b/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_config.h
new file mode 100644
index 000000000000..5939ed4ff92a
--- /dev/null
+++ b/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_config.h
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- ksqlanalyzer/tds/config.h.orig
++++ ksqlanalyzer/tds/config.h
+@@ -58,6 +58,9 @@
+
+ /* Define if you have the atoll function. */
+ #define HAVE_ATOLL 1
++#if __FreeBSD__ < 5
++#undef HAVE_ATOLL
++#endif
+
+ /* Define if you have the vasprintf function. */
+ #define HAVE_VASPRINTF 1
diff --git a/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_tds.h b/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_tds.h
new file mode 100644
index 000000000000..814f3b718022
--- /dev/null
+++ b/databases/ksqlanalyzer/files/patch-ksqlanalyzer_tds_tds.h
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- ksqlanalyzer/tds/tds.h.orig
++++ ksqlanalyzer/tds/tds.h
+@@ -51,9 +51,6 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <time.h>
+-#ifdef HAVE_MALLOC_H
+-#include <malloc.h>
+-#endif
+ #include <sys/time.h>
+ #endif
+
diff --git a/databases/ksqlanalyzer/pkg-descr b/databases/ksqlanalyzer/pkg-descr
new file mode 100644
index 000000000000..1fbdb63e9d6c
--- /dev/null
+++ b/databases/ksqlanalyzer/pkg-descr
@@ -0,0 +1,13 @@
+The KSqlAnalyzer is a tool for easy accessing the data of a MS-SQL-Database.
+It is made for developing and testing new SQL-Query's direclty on the Server.
+The functionality and the look&feel are similar to the program
+'SQL-Query-Analyzer' written by Microsoft.
+
+The KSqlAnalyzer is using parts of the TDS-Library (Version 0.60) from the
+FreeTDS-Project.
+The parts of the library are included into the software, so that there is no
+need to install these Libraries on the Client-machine.
+The Editor is using parts of the KWrite-Sourcecode becaus of the brilliant
+Syntax-Highlighting.
+
+WWW: http://www.kpage.de/en/
diff --git a/databases/ksqlanalyzer/pkg-plist b/databases/ksqlanalyzer/pkg-plist
new file mode 100644
index 000000000000..a63713355e90
--- /dev/null
+++ b/databases/ksqlanalyzer/pkg-plist
@@ -0,0 +1,13 @@
+bin/ksqlanalyzer
+share/applnk/Applications/ksqlanalyzer.desktop
+share/icons/locolor/16x16/apps/ksqlanalyzer.png
+share/icons/locolor/32x32/apps/ksqlanalyzer.png
+share/locale/de/LC_MESSAGES/ksqlanalyzer.mo
+@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true