aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-28 17:36:56 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-28 17:36:56 +0800
commitea3c160881eb60292f774b135239dcf59b5fdfaa (patch)
tree5b1656d091ca74a23ee2a9be5fc60e5f9fc374fb /databases
parent6d36f8955989ea766354bf6dc7b19885bf353df8 (diff)
downloadfreebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.tar.gz
freebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.tar.zst
freebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.zip
Downgrade C++03 to C++98, actual default for GCC < 6
GCC 4.2 in base system doesn't support C++03: cc1plus: error: unrecognized command line option "-std=gnu++03"
Diffstat (limited to 'databases')
-rw-r--r--databases/fastdb/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 9a4e6b8c5f35..917b02ec25ce 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -12,10 +12,6 @@ COMMENT= Main Memory Relational Database Management System
LICENSE= MIT
-BROKEN_mips= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_mips64= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
-
USES= gmake dos2unix
USE_GCC= any
MAKE_ENV= OSTYPE="${OPSYS}"
@@ -31,7 +27,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= FastDB.htm
# The port does not build with C++11 or later (bug 219275).
-USE_CXXSTD= gnu++03
+USE_CXXSTD= gnu++98
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}