aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-03 02:03:43 +0800
committerknu <knu@FreeBSD.org>2001-06-03 02:03:43 +0800
commitec38b81fccb9ef54b92e599cf8961d83b7fc68e7 (patch)
tree6c5df318de7fac32d2707133ab486efe6d85ab63 /databases
parent801db6e65a77206ddc6c671416d38e455b8d154a (diff)
downloadfreebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.tar.gz
freebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.tar.zst
freebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.zip
Add ruby-dbd_postgresql, the PostgreSQL driver for DBI-for-Ruby.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-dbd_postgresql/Makefile42
-rw-r--r--databases/ruby-dbd_postgresql/distinfo1
-rw-r--r--databases/ruby-dbd_postgresql/pkg-comment1
-rw-r--r--databases/ruby-dbd_postgresql/pkg-descr3
-rw-r--r--databases/ruby-dbd_postgresql/pkg-plist9
6 files changed, 57 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6355a688322f..7c932cfccfa8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -72,6 +72,7 @@
SUBDIR += ruby-bdb
SUBDIR += ruby-cdb
SUBDIR += ruby-dbd_mysql
+ SUBDIR += ruby-dbd_postgresql
SUBDIR += ruby-dbi
SUBDIR += ruby-gdbm
SUBDIR += ruby-rdbc1
diff --git a/databases/ruby-dbd_postgresql/Makefile b/databases/ruby-dbd_postgresql/Makefile
new file mode 100644
index 000000000000..6c540a80dbed
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: dbd_postgresql for DBD-for-Ruby
+# Date created: 3 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_postgresql
+PORTVERSION= 0.0.4
+CATEGORIES= databases ruby
+MASTER_SITES= ftp://ftp.one.net/pub/users/jweirich/tools/ruby-dbi/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-dbi-postgresql-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${.CURDIR}/../ruby-dbi \
+ ${RUBY_SITEARCHLIBDIR}/postgres.so:${.CURDIR}/../ruby-postgres
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+EXAMPLES_EN= *.rb
+DOCS_EN= README
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dbi/*.rb ${RUBY_SITELIBDIR}/dbi/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/dbi/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/dbi/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_postgresql/distinfo b/databases/ruby-dbd_postgresql/distinfo
new file mode 100644
index 000000000000..c84daf3e6cab
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-dbi-postgresql-0.0.4.tgz) = 14ae1d7428e2f4a03108cbad67305587
diff --git a/databases/ruby-dbd_postgresql/pkg-comment b/databases/ruby-dbd_postgresql/pkg-comment
new file mode 100644
index 000000000000..e5eabfa618d9
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-comment
@@ -0,0 +1 @@
+PostgreSQL driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_postgresql/pkg-descr b/databases/ruby-dbd_postgresql/pkg-descr
new file mode 100644
index 000000000000..03a6942dd360
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-descr
@@ -0,0 +1,3 @@
+This is the PostgreSQL driver for Rainer Perl's DBI-for-Ruby.
+
+Author: Jim Weirich <jweirich@one.ent>
diff --git a/databases/ruby-dbd_postgresql/pkg-plist b/databases/ruby-dbd_postgresql/pkg-plist
new file mode 100644
index 000000000000..5562f2c6f957
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITELIBDIR%%/dbi/dbd_postgresql.rb
+%%RUBY_SITELIBDIR%%/dbi/sqlquote.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/runtests.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testdbi.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testdbipostgres.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testsqlquote.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dbi/dbd_postgresql/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/dbi/dbd_postgresql