aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-03 02:03:43 +0800
committerknu <knu@FreeBSD.org>2001-06-03 02:03:43 +0800
commitec38b81fccb9ef54b92e599cf8961d83b7fc68e7 (patch)
tree6c5df318de7fac32d2707133ab486efe6d85ab63 /databases
parent801db6e65a77206ddc6c671416d38e455b8d154a (diff)
downloadfreebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.tar.gz
freebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.tar.zst
freebsd-ports-gnome-ec38b81fccb9ef54b92e599cf8961d83b7fc68e7.zip
Add ruby-dbd_postgresql, the PostgreSQL driver for DBI-for-Ruby.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-dbd_postgresql/Makefile42
-rw-r--r--databases/ruby-dbd_postgresql/distinfo1
-rw-r--r--databases/ruby-dbd_postgresql/pkg-comment1
-rw-r--r--databases/ruby-dbd_postgresql/pkg-descr3
-rw-r--r--databases/ruby-dbd_postgresql/pkg-plist9
6 files changed, 57 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6355a688322f..7c932cfccfa8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -72,6 +72,7 @@
SUBDIR += ruby-bdb
SUBDIR += ruby-cdb
SUBDIR += ruby-dbd_mysql
+ SUBDIR += ruby-dbd_postgresql
SUBDIR += ruby-dbi
SUBDIR += ruby-gdbm
SUBDIR += ruby-rdbc1
diff --git a/databases/ruby-dbd_postgresql/Makefile b/databases/ruby-dbd_postgresql/Makefile
new file mode 100644
index 000000000000..6c540a80dbed
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: dbd_postgresql for DBD-for-Ruby
+# Date created: 3 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_postgresql
+PORTVERSION= 0.0.4
+CATEGORIES= databases ruby
+MASTER_SITES= ftp://ftp.one.net/pub/users/jweirich/tools/ruby-dbi/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-dbi-postgresql-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${.CURDIR}/../ruby-dbi \
+ ${RUBY_SITEARCHLIBDIR}/postgres.so:${.CURDIR}/../ruby-postgres
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+EXAMPLES_EN= *.rb
+DOCS_EN= README
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dbi/*.rb ${RUBY_SITELIBDIR}/dbi/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/dbi/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/dbi/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/dbi/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_postgresql/distinfo b/databases/ruby-dbd_postgresql/distinfo
new file mode 100644
index 000000000000..c84daf3e6cab
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-dbi-postgresql-0.0.4.tgz) = 14ae1d7428e2f4a03108cbad67305587
diff --git a/databases/ruby-dbd_postgresql/pkg-comment b/databases/ruby-dbd_postgresql/pkg-comment
new file mode 100644
index 000000000000..e5eabfa618d9
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-comment
@@ -0,0 +1 @@
+PostgreSQL driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_postgresql/pkg-descr b/databases/ruby-dbd_postgresql/pkg-descr
new file mode 100644
index 000000000000..03a6942dd360
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-descr
@@ -0,0 +1,3 @@
+This is the PostgreSQL driver for Rainer Perl's DBI-for-Ruby.
+
+Author: Jim Weirich <jweirich@one.ent>
diff --git a/databases/ruby-dbd_postgresql/pkg-plist b/databases/ruby-dbd_postgresql/pkg-plist
new file mode 100644
index 000000000000..5562f2c6f957
--- /dev/null
+++ b/databases/ruby-dbd_postgresql/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITELIBDIR%%/dbi/dbd_postgresql.rb
+%%RUBY_SITELIBDIR%%/dbi/sqlquote.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/runtests.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testdbi.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testdbipostgres.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql/testsqlquote.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/dbi/dbd_postgresql
+%%PORTDOCS%%%%RUBY_DOCDIR%%/dbi/dbd_postgresql/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/dbi/dbd_postgresql
deletions'>-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.86/CHANGES * - Revert ports/165605 as requested by portmgr@pgollucci2012-03-142-1/+23 | | | | | | | | | Note: devel/p5-B-Size and devel/p5-Devel-Arena where intentionally not restored. PR: ports/165605 Approved by: portmgr (bapt) Feature safe: yes (I sure hope so) * - Remove ports that only work with < perl 5.12 (devel/p5-B-Size, ↵pgollucci2012-03-092-23/+1 | | | | | | | | | | | | | | | devel/p5-Devel-Arena) - Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index * - Update to 1.84jadawin2012-03-052-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.84/CHANGES * - Update to 1.82jadawin2011-11-222-3/+3 | | | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.82/CHANGES Feature safe: yes * - Update to 1.80jadawin2011-10-182-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.80/CHANGES * - Update to 1.78jadawin2011-09-092-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.78/CHANGES * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-06-201-1/+1 | | | | | | See http://wiki.freebsd.org/Perl for details. - Change maintainership from ports@ to perl@ for ports in this changeset. - Remove MD5 checksum * - Update to 1.76jadawin2011-01-112-3/+4 | | | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.76/CHANGES Feature safe: yes * - Update to 1.74jadawin2010-12-282-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.74/CHANGES * - Update to 1.72jadawin2010-11-192-3/+3 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.72/CHANGES * - Update to 1.70jadawin2010-11-162-5/+3 | | | | - Changelog: http://search.cpan.org/src/BINGOS/Archive-Tar-1.70/CHANGES * Change dependency on old p5-Compress-Zlib, p5-IO-Compress-Base,mm2010-09-211-3/+4 | | | | | | p5-IO-Compress-Zlib and p5-IO-Compress-Bzip2 modules to p5-IO-Compress. Explicitly depend on p5-IO-Compress only if PERL_LEVEL < 500903 Bump PORTREVISION * - Update to 1.68jadawin2010-08-242-4/+4 | | | | | | | - Changelog: <http://search.cpan.org/dist/Archive-Tar/CHANGES> PR: ports/149877 Submitted by: Frederic Culot <frederic _AT_ culot.org> * - Update to 1.66jadawin2010-07-272-4/+4 | | | | - Changelog: <http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.66/CHANGES> * - Update to 1.64jadawin2010-07-152-4/+4 | | | | - Changelog: <http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.64/CHANGES> * - Update to 1.62jadawin2010-06-292-4/+4 | | | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.62/CHANGES Feature safe: yes * - Update to 1.60jadawin2010-05-052-4/+4 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.60/CHANGES * - Update to 1.56jadawin2010-02-042-4/+4 | | | | - Changelog: http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.56/CHANGES * - Update to 1.54jadawin2009-09-112-4/+4 | | | | - Changelog : http://cpansearch.perl.org/src/BINGOS/Archive-Tar-1.54/CHANGES * - Update to 1.52jadawin2009-06-152-4/+4 | * - Update to 1.48jadawin2009-04-232-4/+4 | * Introduce Perl 5.10.0skv2009-03-292-3/+15 | * - Update to 1.46jadawin2009-03-092-4/+4 | * - Update to 1.44jadawin2009-01-222-5/+5 | | | | - Take maintainership * - Update to 1.42jadawin2008-12-162-4/+4 | * - update to 1.40leeym2008-10-182-8/+14 | * - use CPAN macroleeym2008-02-261-3/+2 | | | | | - remove the modules which are in perl core list from dependency - bump PORTREVISION * - Update to 1.38gabor2007-12-272-4/+4 | * - Update to 1.36miwi2007-09-172-4/+4 | * - Update to 1.34clsung2007-08-162-4/+4 | * - Update to 1.32clsung2007-05-292-8/+4 | * - Update to 1.31clsung2007-05-252-4/+4 | | | | | PR: ports/112965 Submitted by: Thomas Abthorpe <thomas_AT_goodking dot ca> * - update to 1.30clsung2006-08-022-5/+4 | * - update to 1.29leeym2006-03-18