aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-07-14 17:14:11 +0800
committertz <tz@FreeBSD.org>2017-07-14 17:14:11 +0800
commitef74c4c775d8403430df40079ae6dfbdebbafc79 (patch)
tree18f0444e7237583f750bec6bde3bf6956b2968cb /databases
parent6a7c057d4119f7a93ee402cfec6cf09c4e897213 (diff)
downloadfreebsd-ports-gnome-ef74c4c775d8403430df40079ae6dfbdebbafc79.tar.gz
freebsd-ports-gnome-ef74c4c775d8403430df40079ae6dfbdebbafc79.tar.zst
freebsd-ports-gnome-ef74c4c775d8403430df40079ae6dfbdebbafc79.zip
New port: databases/postgresql-tds_fdw
Tds_fdw is a PostgreSQL foreign data wrapper that can connect to databases that use the Tabular Data Stream (TDS) protocol, such as Sybase databases and Microsoft SQL server. The current version does not yet support JOIN push-down, or write operations. It does support WHERE and column pushdowns when match_column_names is enabled. WWW: https://github.com/tds-fdw/tds_fdw PR: 219671 Submitted by: Jov <amutu@amutu.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-tds_fdw/Makefile29
-rw-r--r--databases/postgresql-tds_fdw/distinfo3
-rw-r--r--databases/postgresql-tds_fdw/pkg-descr7
4 files changed, 40 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 37ee8e5cdbb2..74e2b9a817f3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -671,6 +671,7 @@
SUBDIR += postgresql-relay
SUBDIR += postgresql-repmgr
SUBDIR += postgresql-repmgr2
+ SUBDIR += postgresql-tds_fdw
SUBDIR += postgresql92-client
SUBDIR += postgresql92-contrib
SUBDIR += postgresql92-docs
diff --git a/databases/postgresql-tds_fdw/Makefile b/databases/postgresql-tds_fdw/Makefile
new file mode 100644
index 000000000000..92feeccf30c2
--- /dev/null
+++ b/databases/postgresql-tds_fdw/Makefile
@@ -0,0 +1,29 @@
+# Created by: Jov amutu@amutu.com
+# $FreeBSD$
+
+PORTNAME= tds_fdw
+PORTVERSION= 1.0.8
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= amutu@amutu.com
+COMMENT= PostgreSQL foreign data wrapper to connect to TDS databases
+
+LICENSE= PostgreSQL
+
+LIB_DEPENDS= libodbc.so:databases/freetds
+
+USES= gmake pgsql:9.2+
+USE_GITHUB= yes
+GH_ACCOUNT= tds-fdw
+
+PLIST_FILES= lib/postgresql/tds_fdw.so \
+ share/doc/postgresql/extension/README.tds_fdw.md \
+ share/postgresql/extension/tds_fdw--1.0.8.sql \
+ share/postgresql/extension/tds_fdw.control
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/tds_fdw.so
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-tds_fdw/distinfo b/databases/postgresql-tds_fdw/distinfo
new file mode 100644
index 000000000000..2168cd0785dd
--- /dev/null
+++ b/databases/postgresql-tds_fdw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1496200478
+SHA256 (tds-fdw-tds_fdw-v1.0.8_GH0.tar.gz) = 2afb64f3a2f125561c379008bd09ffe00d92b2a970dd8fe6af56230890090c6f
+SIZE (tds-fdw-tds_fdw-v1.0.8_GH0.tar.gz) = 23145
diff --git a/databases/postgresql-tds_fdw/pkg-descr b/databases/postgresql-tds_fdw/pkg-descr
new file mode 100644
index 000000000000..4e9071249938
--- /dev/null
+++ b/databases/postgresql-tds_fdw/pkg-descr
@@ -0,0 +1,7 @@
+Tds_fdw is a PostgreSQL foreign data wrapper that can connect to databases that
+use the Tabular Data Stream (TDS) protocol, such as Sybase databases and
+Microsoft SQL server. The current version does not yet support JOIN push-down,
+or write operations. It does support WHERE and column pushdowns when
+match_column_names is enabled.
+
+WWW: https://github.com/tds-fdw/tds_fdw