aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-09 23:53:10 +0800
committerknu <knu@FreeBSD.org>2001-06-09 23:53:10 +0800
commitf89266dd2b5c56de92dcdb8f0a1f588d59896e32 (patch)
tree95fc4180be6ad97e641a92f0ee89691b7944f6a4 /databases
parent1273104b9ed544032c83b8636d3f342186ed0782 (diff)
downloadfreebsd-ports-gnome-f89266dd2b5c56de92dcdb8f0a1f588d59896e32.tar.gz
freebsd-ports-gnome-f89266dd2b5c56de92dcdb8f0a1f588d59896e32.tar.zst
freebsd-ports-gnome-f89266dd2b5c56de92dcdb8f0a1f588d59896e32.zip
Add ruby-dbd_msql, the mSQL driver for DBI-for-Ruby.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-dbd_msql/Makefile29
-rw-r--r--databases/ruby-dbd_msql/pkg-comment1
-rw-r--r--databases/ruby-dbd_msql/pkg-descr4
-rw-r--r--databases/ruby-dbd_msql/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 92b8e90ef4ad..c01c9c0be847 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -71,6 +71,7 @@
SUBDIR += rdb
SUBDIR += ruby-bdb
SUBDIR += ruby-cdb
+ SUBDIR += ruby-dbd_msql
SUBDIR += ruby-dbd_mysql
SUBDIR += ruby-dbd_odbc
SUBDIR += ruby-dbd_pg
diff --git a/databases/ruby-dbd_msql/Makefile b/databases/ruby-dbd_msql/Makefile
new file mode 100644
index 000000000000..5452d1b414c1
--- /dev/null
+++ b/databases/ruby-dbd_msql/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dbd_msql for DBD-for-Ruby
+# Date created: 10 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbd_msql
+PORTVERSION= ${RUBY_DBI_PORTVERSION}
+CATEGORIES= databases ruby
+MASTER_SITES= ${RUBY_DBI_MASTER_SITES}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_DBI_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
+ ${RUBY_SITEARCHLIBDIR}/msql.so:${.CURDIR}/../ruby-msql
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+WRKSRC= ${RUBY_DBI_WRKSRC}
+CONFIGURE_ARGS= --with=lib/${PORTNAME}
+
+.include "${.CURDIR}/../ruby-dbi/Makefile.common"
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-dbd_msql/pkg-comment b/databases/ruby-dbd_msql/pkg-comment
new file mode 100644
index 000000000000..524db2a9d179
--- /dev/null
+++ b/databases/ruby-dbd_msql/pkg-comment
@@ -0,0 +1 @@
+mSQL driver for DBI-for-Ruby
diff --git a/databases/ruby-dbd_msql/pkg-descr b/databases/ruby-dbd_msql/pkg-descr
new file mode 100644
index 000000000000..b7bdf8748e1a
--- /dev/null
+++ b/databases/ruby-dbd_msql/pkg-descr
@@ -0,0 +1,4 @@
+This is the mSQL driver for DBI-for-Ruby.
+
+Author: Michael Neumann <neumann@s-direktnet.de>
+WWW: http://www.ruby-projects.org/dbi/
diff --git a/databases/ruby-dbd_msql/pkg-plist b/databases/ruby-dbd_msql/pkg-plist
new file mode 100644
index 000000000000..1eb7517c201d
--- /dev/null
+++ b/databases/ruby-dbd_msql/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITELIBDIR%%/DBD/Msql/Msql.rb
+@dirrm %%RUBY_SITELIBDIR%%/DBD/Msql