aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-06-02 07:03:37 +0800
committermarino <marino@FreeBSD.org>2016-06-02 07:03:37 +0800
commitfa55810f7a6353fcb9c2a0637047f7ead27550cd (patch)
tree797ea7be3e3bd63821497c7b6ddd0878f3b1961a /databases
parent29f6233bdcd0941ab1948e869c706241b197a5be (diff)
downloadfreebsd-ports-gnome-fa55810f7a6353fcb9c2a0637047f7ead27550cd.tar.gz
freebsd-ports-gnome-fa55810f7a6353fcb9c2a0637047f7ead27550cd.tar.zst
freebsd-ports-gnome-fa55810f7a6353fcb9c2a0637047f7ead27550cd.zip
databases/luadbi is not jobs safe
I've witnessed this port fail two separate times because it doesn't ensure that the "build" directory has been created before it starts constructing object files.
Diffstat (limited to 'databases')
-rw-r--r--databases/luadbi/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/databases/luadbi/Makefile b/databases/luadbi/Makefile
index deff14ea3554..2c60d641f161 100644
--- a/databases/luadbi/Makefile
+++ b/databases/luadbi/Makefile
@@ -18,6 +18,8 @@ NO_WRKSUBDIR= yes
USES= gmake lua:51 shebangfix
SHEBANG_FILES= DBI.lua
+MAKE_JOBS_UNSAFE= yes
+
CFLAGS+= -fpic -I${LOCALBASE}/include -I${LUA_INCDIR} -I. \
-I${LOCALBASE}/include/postgresql/server
LDFLAGS+= -shared -L${LOCALBASE}/lib -L${LUA_LIBDIR}