aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-19 21:00:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-19 21:00:47 +0800
commit146bac8592b0a1ce60cb2e51673cbc1b21d530b0 (patch)
treece8d23d0e1cf27dedf69de8a0b08ba136cec4b76 /databases
parent397bae781022d8c4b5b784b436068237f0bf3bbb (diff)
downloadfreebsd-ports-gnome-146bac8592b0a1ce60cb2e51673cbc1b21d530b0.tar.gz
freebsd-ports-gnome-146bac8592b0a1ce60cb2e51673cbc1b21d530b0.tar.zst
freebsd-ports-gnome-146bac8592b0a1ce60cb2e51673cbc1b21d530b0.zip
- Convert to new options framework
- Rename option PERFTOOLS to GPERFTOOLS to match the project name
Diffstat (limited to 'databases')
-rw-r--r--databases/leveldb/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index fcad2bf74dd0..ed9e97dedc0f 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A fast and lightweight key/value database library by Google
-OPTIONS= PERFTOOLS "Build with Google perftools" off \
- SNAPPY "Build with snappy" on
+OPTIONS_DEFINE= GPERFTOOLS SNAPPY
+OPTIONS_DEFAULT=SNAPPY
LDFLAGS+= -L${LOCALBASE}/lib
USE_GMAKE= yes
@@ -31,11 +31,11 @@ SHLIB_MINOR= ${PORTVERSION:R:E}
.include <bsd.port.options.mk>
-.if defined(WITH_PERFTOOLS)
+.if ${PORT_OPTIONS:MGPERFTOOLS}
LIB_DEPENDS+= tcmalloc:${PORTSDIR}/devel/google-perftools
.endif
-.if !defined(WITHOUT_SNAPPY)
+.if ${PORT_OPTIONS:MSNAPPY}
LIB_DEPENDS+= snappy:${PORTSDIR}/archivers/snappy
SNAPPY= 1
.else
@@ -44,10 +44,10 @@ SNAPPY= 0
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/build_detect_platform
-.if !defined(WITH_PERFTOOLS)
+.if empty(PORT_OPTIONS:MGPERFTOOLS)
@${REINPLACE_CMD} -e 's| -ltcmalloc||' ${WRKSRC}/build_detect_platform
.endif
-.if defined(WITHOUT_SNAPPY)
+.if empty(PORT_OPTIONS:MSNAPPY)
@${REINPLACE_CMD} -e 's| -DSNAPPY||; s| -lsnappy||' ${WRKSRC}/build_detect_platform
.endif