aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-09-07 19:16:17 +0800
committerrakuco <rakuco@FreeBSD.org>2015-09-07 19:16:17 +0800
commit1adfecd8d8ec1e67fcd00fa63081de4b90a865a4 (patch)
tree74eb1fc7dd372ebadc2e124411ab7c148d23c276 /databases
parent433fb277a912325aae83e569a7c6de14468d34f5 (diff)
downloadfreebsd-ports-gnome-1adfecd8d8ec1e67fcd00fa63081de4b90a865a4.tar.gz
freebsd-ports-gnome-1adfecd8d8ec1e67fcd00fa63081de4b90a865a4.tar.zst
freebsd-ports-gnome-1adfecd8d8ec1e67fcd00fa63081de4b90a865a4.zip
Switch to USES=libedit.
Instead of manually adding both a build- and a run-time dependency on libedit from ports, use USES=libedit instead. Not only does it take care of adding the proper dependency, but it also sets CMAKE_PREFIX_PATH to ${LOCALBASE} to make sure that the version in ports is preferred instead of the one in base. This is a dependency for moving to CMake 3.3.x, as starting with 3.3.0 calls to find_library() will also look in the $PATH environment variable and end up finding libedit from base by default (see bug 202516). PR: 202618 Approved by: maintainer timeout (ale, 14 days)
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql56-server/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/mysql56-server/Makefile b/databases/mysql56-server/Makefile
index ef67dcb89c0d..f73327394d32 100644
--- a/databases/mysql56-server/Makefile
+++ b/databases/mysql56-server/Makefile
@@ -64,8 +64,7 @@ MMAN1= my_print_defaults.1 myisam_ftdump.1 myisamchk.1 myisamlog.1 myisampack.1
CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON"
.else
-BUILD_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
-RUN_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
+USES+= libedit
.endif
post-patch:
@@ -76,5 +75,5 @@ post-patch:
.if ${ARCH} == "armv6"
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
.endif
-
+
.include <bsd.port.post.mk>