aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2010-02-07 22:16:00 +0800
committermarkus <markus@FreeBSD.org>2010-02-07 22:16:00 +0800
commit276cb088f705d85af4ec51bbac01c6d20d76f6ef (patch)
treebc8911211e0b79b4c94bf1ee2b295018eafc3c4e /databases
parent9f77bfd0743e7af542406670a109e8299c9acb1d (diff)
downloadfreebsd-ports-gnome-276cb088f705d85af4ec51bbac01c6d20d76f6ef.tar.gz
freebsd-ports-gnome-276cb088f705d85af4ec51bbac01c6d20d76f6ef.tar.zst
freebsd-ports-gnome-276cb088f705d85af4ec51bbac01c6d20d76f6ef.zip
Update to version 0.2.3
Diffstat (limited to 'databases')
-rw-r--r--databases/kbibtex/Makefile5
-rw-r--r--databases/kbibtex/distinfo6
-rw-r--r--databases/kbibtex/files/patch-src-fileexporterbibtex.cpp11
-rw-r--r--databases/kbibtex/files/patch-src-fileimporterbibtex.cpp11
-rw-r--r--databases/kbibtex/pkg-plist20
5 files changed, 41 insertions, 12 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index a1d208cabe09..7bcaa37ff98e 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -5,14 +5,15 @@
# $FreeBSD$
PORTNAME= kbibtex
-PORTVERSION= 0.2.1
-PORTREVISION= 3
+PORTVERSION= 0.2.3
CATEGORIES= databases kde
MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/download/
MAINTAINER= markus@FreeBSD.org
COMMENT= BibTeX editor for KDE
+LIB_DEPENDS= yaz.3:${PORTSDIR}/net/yaz
+
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/databases/kbibtex/distinfo b/databases/kbibtex/distinfo
index b37a2e187a8e..739673e25254 100644
--- a/databases/kbibtex/distinfo
+++ b/databases/kbibtex/distinfo
@@ -1,3 +1,3 @@
-MD5 (kbibtex-0.2.1.tar.bz2) = 8d2b142a8878e86398a30786ede674e1
-SHA256 (kbibtex-0.2.1.tar.bz2) = 4dc06a303aef942025d75a34e7ffde25b36c6c71e661cabeb1c8e3117f7e1af8
-SIZE (kbibtex-0.2.1.tar.bz2) = 722618
+MD5 (kbibtex-0.2.3.tar.bz2) = 211075c5e096e71f1bc311acb5777eff
+SHA256 (kbibtex-0.2.3.tar.bz2) = 2a2628564c2337d8cf94742c5231261655cf89ad59b6e3f3f1fabedc3a37d82b
+SIZE (kbibtex-0.2.3.tar.bz2) = 841523
diff --git a/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp b/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp
new file mode 100644
index 000000000000..1138cfa90e21
--- /dev/null
+++ b/databases/kbibtex/files/patch-src-fileexporterbibtex.cpp
@@ -0,0 +1,11 @@
+--- src/fileexporterbibtex.cpp.orig 2010-02-01 19:08:49.000000000 +0100
++++ src/fileexporterbibtex.cpp 2010-02-01 19:17:03.000000000 +0100
+@@ -258,7 +258,7 @@
+ for ( i = 0; i < encodeMaxTries && utf8datasize != 0; ++i )
+ {
+ QCString utf8 = workingText.utf8();
+- char *utf8data = utf8.data();
++ const char *utf8data = utf8.data();
+ utf8datasize = utf8.length();
+ char *outputdata = m_iconvBuffer;
+ size_t outputdatasize = m_iconvBufferSize;
diff --git a/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp b/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp
new file mode 100644
index 000000000000..df7a7125063e
--- /dev/null
+++ b/databases/kbibtex/files/patch-src-fileimporterbibtex.cpp
@@ -0,0 +1,11 @@
+--- src/fileimporterbibtex.cpp.orig 2010-02-01 19:17:54.000000000 +0100
++++ src/fileimporterbibtex.cpp 2010-02-01 19:18:23.000000000 +0100
+@@ -67,7 +67,7 @@
+ {
+ evaluateParameterComments( iconvHandle, m_lineBuffer );
+
+- char *raw = m_lineBuffer;
++ const char *raw = m_lineBuffer;
+ char *enc = convertedLine;
+ size_t encLen = m_lineBufferSize, rawLen = ( size_t )len;
+ size_t result = iconv( iconvHandle, &raw, &rawLen, &enc, &encLen );
diff --git a/databases/kbibtex/pkg-plist b/databases/kbibtex/pkg-plist
index b33a38f7b39d..aa471ab24524 100644
--- a/databases/kbibtex/pkg-plist
+++ b/databases/kbibtex/pkg-plist
@@ -4,22 +4,28 @@ lib/kde3/libkbibtexpart.la
lib/kde3/libkbibtexpart.so
share/applications/kde/kbibtex.desktop
share/apps/kbibtex/kbibtex_shell.rc
+share/apps/kbibtex/z3950-servers.cfg
share/apps/kbibtexpart/kbibtex_part.rc
+share/apps/kbibtexpart/xslt/MARC21slim2MODS3.xsl
+share/apps/kbibtexpart/xslt/MARC21slimUtils.xsl
+share/apps/kbibtexpart/xslt/UNIMARC2MODS3.xsl
share/apps/kbibtexpart/xslt/html.xsl
share/doc/HTML/en/kbibtex/common
share/doc/HTML/en/kbibtex/index.cache.bz2
share/doc/HTML/en/kbibtex/index.docbook
-share/icons/crystalsvg/128x128/apps/kbibtex.png
-share/icons/crystalsvg/16x16/apps/kbibtex.png
-share/icons/crystalsvg/22x22/apps/kbibtex.png
-share/icons/crystalsvg/32x32/apps/kbibtex.png
-share/icons/crystalsvg/48x48/apps/kbibtex.png
-share/icons/crystalsvg/64x64/apps/kbibtex.png
+share/icons/hicolor/128x128/apps/kbibtex.png
+share/icons/hicolor/16x16/apps/kbibtex.png
+share/icons/hicolor/22x22/apps/kbibtex.png
+share/icons/hicolor/32x32/apps/kbibtex.png
+share/icons/hicolor/48x48/apps/kbibtex.png
+share/icons/hicolor/64x64/apps/kbibtex.png
share/locale/de/LC_MESSAGES/kbibtex.mo
+share/locale/fr/LC_MESSAGES/kbibtex.mo
+share/locale/it/LC_MESSAGES/kbibtex.mo
+share/locale/pl/LC_MESSAGES/kbibtex.mo
share/locale/ru/LC_MESSAGES/kbibtex.mo
share/services/kbibtex_part.desktop
@dirrm share/doc/HTML/en/kbibtex
@dirrm share/apps/kbibtexpart/xslt
@dirrm share/apps/kbibtexpart
@dirrm share/apps/kbibtex
-@dirrmtry share/applications/kde