aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2012-08-15 21:37:44 +0800
committerolgeni <olgeni@FreeBSD.org>2012-08-15 21:37:44 +0800
commit2cbf03ebd73285d3c0a0b031c6c377bd0768ed25 (patch)
tree6831c49cbb97484fd6cd5dd9bea7f28eb6b5d8bc /databases
parent235797b1cc137750f992ab29411ec20b08ef28eb (diff)
downloadfreebsd-ports-gnome-2cbf03ebd73285d3c0a0b031c6c377bd0768ed25.tar.gz
freebsd-ports-gnome-2cbf03ebd73285d3c0a0b031c6c377bd0768ed25.tar.zst
freebsd-ports-gnome-2cbf03ebd73285d3c0a0b031c6c377bd0768ed25.zip
Patch ports depending on lang/erlang-lite to use lang/erlang instead.
The current lang/erlang option defaults match those specified in lang/erlang-lite, thus making it redundant. Also, mixing ports depending on lang/erlang and lang/erlang-lite is impossible without manual patching. Hence, lang/erlang-lite is going to be removed.
Diffstat (limited to 'databases')
-rw-r--r--databases/couchdb/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index d86f3d769142..4e5ee00b2b12 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
js:${PORTSDIR}/lang/spidermonkey \
curl:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:${PORTSDIR}/misc/help2man \
- erlc:${ERLANG_PORT}
-RUN_DEPENDS= erl:${ERLANG_PORT}
+ erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
USERS= couchdb
GROUPS= couchdb
@@ -38,19 +38,10 @@ CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
--with-js-lib=${LOCALBASE}/lib
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-OPTIONS_DEFINE= ERLANG
-ERLANG_DESC= Use lang/erlang instead of lang/erlang-lite
-
MAN1= couchdb.1 couchjs.1
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MERLANG}
-ERLANG_PORT= ${PORTSDIR}/lang/erlang
-.else
-ERLANG_PORT= ${PORTSDIR}/lang/erlang-lite
-.endif
-
# This stanza could be removed around version 1.7
pre-everything::
@if [ -f ${PREFIX}/etc/couchdb/local.ini -a \