aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2015-05-21 08:58:26 +0800
committerdelphij <delphij@FreeBSD.org>2015-05-21 08:58:26 +0800
commit37aaf441192fdd6fbbc107e17742035d81822e08 (patch)
tree5ce75b32d11b7ba9331084c8edd5b66557f311bd /databases
parentd44dbadadcc2d477db1ba33328ffa733411e1be9 (diff)
downloadfreebsd-ports-gnome-37aaf441192fdd6fbbc107e17742035d81822e08.tar.gz
freebsd-ports-gnome-37aaf441192fdd6fbbc107e17742035d81822e08.tar.zst
freebsd-ports-gnome-37aaf441192fdd6fbbc107e17742035d81822e08.zip
Update to 0.6.0.
Submitted by: KATO Tsuguru <tkato432 yahoo com>
Diffstat (limited to 'databases')
-rw-r--r--databases/beansdb/Makefile15
-rw-r--r--databases/beansdb/distinfo4
-rw-r--r--databases/beansdb/files/patch-configure.ac10
-rw-r--r--databases/beansdb/files/patch-src__bitcask.c26
-rw-r--r--databases/beansdb/files/patch-src__codec.c11
-rw-r--r--databases/beansdb/files/patch-src__hstore.c19
-rw-r--r--databases/beansdb/files/patch-src__htree.c67
-rw-r--r--databases/beansdb/pkg-descr8
8 files changed, 147 insertions, 13 deletions
diff --git a/databases/beansdb/Makefile b/databases/beansdb/Makefile
index 262da69472de..cc90550acaf9 100644
--- a/databases/beansdb/Makefile
+++ b/databases/beansdb/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= beansdb
-PORTVERSION= 0.5.3
+PORTVERSION= 0.6.0
+DISTVERSIONPREFIX= v
CATEGORIES= databases
-MASTER_SITES= GOOGLE_CODE \
- http://mirror.amdmi3.ru/googlecode/
+MASTER_SITES= GH
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another distributed key-value storage system from Douban Inc
@@ -13,11 +13,12 @@ COMMENT= Yet another distributed key-value storage system from Douban Inc
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_GITHUB= yes
+GH_ACCOUNT= douban
+
+USES= autoreconf
GNU_CONFIGURE= yes
-USE_CSTD= gnu89
-LDFLAGS+= -lpthread
-PLIST_FILES= bin/beansdb \
- man/man1/beansdb.1.gz
+PLIST_FILES= bin/beansdb man/man1/beansdb.1.gz
.include <bsd.port.mk>
diff --git a/databases/beansdb/distinfo b/databases/beansdb/distinfo
index ab3d84edfe1c..4e87511f60fe 100644
--- a/databases/beansdb/distinfo
+++ b/databases/beansdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (beansdb-0.5.3.tar.gz) = 5b0927c80e279750285bc05473369b45552c2af235634a234f2aaefbc98d6edc
-SIZE (beansdb-0.5.3.tar.gz) = 144363
+SHA256 (douban-beansdb-v0.6.0_GH0.tar.gz) = 64817d3c4dfde3342a2194e39becd17763a8dd854688fe47011017548b6247d8
+SIZE (douban-beansdb-v0.6.0_GH0.tar.gz) = 151711
diff --git a/databases/beansdb/files/patch-configure.ac b/databases/beansdb/files/patch-configure.ac
new file mode 100644
index 000000000000..164e4be26ded
--- /dev/null
+++ b/databases/beansdb/files/patch-configure.ac
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2013-07-17 08:09:12 UTC
++++ configure.ac
+@@ -1,6 +1,6 @@
+ AC_PREREQ(2.61)
+ AC_INIT([beansdb], [0.6.0], [davies.liu@gmail.com])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
++AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_CONFIG_HEADERS([config.h])
diff --git a/databases/beansdb/files/patch-src__bitcask.c b/databases/beansdb/files/patch-src__bitcask.c
new file mode 100644
index 000000000000..0bba64fc75ac
--- /dev/null
+++ b/databases/beansdb/files/patch-src__bitcask.c
@@ -0,0 +1,26 @@
+--- src/bitcask.c.orig 2013-07-17 08:09:12 UTC
++++ src/bitcask.c
+@@ -99,12 +99,12 @@ Bitcask* bc_open2(Mgr *mgr, int depth, i
+ return bc;
+ }
+
+-inline bool file_exists(const char *path) {
++static inline bool file_exists(const char *path) {
+ struct stat st;
+ return stat(path, &st) == 0;
+ }
+
+-inline char *gen_path(char *dst, const char *base, const char *fmt, int i)
++static inline char *gen_path(char *dst, const char *base, const char *fmt, int i)
+ {
+ static char path[256];
+ char name[16];
+@@ -114,7 +114,7 @@ inline char *gen_path(char *dst, const c
+ return dst;
+ }
+
+-inline char *new_path(char *dst, Mgr *mgr, const char *fmt, int i)
++static inline char *new_path(char *dst, Mgr *mgr, const char *fmt, int i)
+ {
+ char *path = gen_path(dst, mgr_base(mgr), fmt, i);
+ if (!file_exists(dst)) {
diff --git a/databases/beansdb/files/patch-src__codec.c b/databases/beansdb/files/patch-src__codec.c
new file mode 100644
index 000000000000..b627a59045cc
--- /dev/null
+++ b/databases/beansdb/files/patch-src__codec.c
@@ -0,0 +1,11 @@
+--- src/codec.c.orig 2013-07-17 08:09:12 UTC
++++ src/codec.c
+@@ -28,7 +28,7 @@ typedef struct {
+ char fmt[7];
+ } Fmt;
+
+-inline int fmt_size(Fmt *fmt) {
++static inline int fmt_size(Fmt *fmt) {
+ return sizeof(Fmt) + strlen(fmt->fmt) - 7 + 1;
+ }
+
diff --git a/databases/beansdb/files/patch-src__hstore.c b/databases/beansdb/files/patch-src__hstore.c
new file mode 100644
index 000000000000..e98b6257bf99
--- /dev/null
+++ b/databases/beansdb/files/patch-src__hstore.c
@@ -0,0 +1,19 @@
+--- src/hstore.c.orig 2013-07-17 08:09:12 UTC
++++ src/hstore.c
+@@ -45,14 +45,14 @@ struct t_hstore {
+ Bitcask* bitcasks[];
+ };
+
+-inline int get_index(HStore *store, char *key)
++static inline int get_index(HStore *store, char *key)
+ {
+ if (store->height == 0) return 0;
+ uint32_t h = fnv1a(key, strlen(key));
+ return h >> ((8 - store->height) * 4);
+ }
+
+-inline pthread_mutex_t* get_mutex(HStore *store, char *key)
++static inline pthread_mutex_t* get_mutex(HStore *store, char *key)
+ {
+ uint32_t i = fnv1a(key, strlen(key)) % NUM_OF_MUTEX;
+ return &store->locks[i];
diff --git a/databases/beansdb/files/patch-src__htree.c b/databases/beansdb/files/patch-src__htree.c
new file mode 100644
index 000000000000..0a20139a0ea1
--- /dev/null
+++ b/databases/beansdb/files/patch-src__htree.c
@@ -0,0 +1,67 @@
+--- src/htree.c.orig 2013-07-17 08:09:12 UTC
++++ src/htree.c
+@@ -74,23 +74,23 @@ static void split_node(HTree *tree, Node
+ static void merge_node(HTree *tree, Node *node);
+ static void update_node(HTree *tree, Node *node);
+
+-inline uint32_t get_pos(HTree *tree, Node *node)
++static inline uint32_t get_pos(HTree *tree, Node *node)
+ {
+ return (node - tree->root) - g_index[(int)node->depth];
+ }
+
+-inline Node *get_child(HTree *tree, Node *node, int b)
++static inline Node *get_child(HTree *tree, Node *node, int b)
+ {
+ int i = g_index[node->depth + 1] + (get_pos(tree, node) << 4) + b;
+ return tree->root + i;
+ }
+
+-inline Data* get_data(Node *node)
++static inline Data* get_data(Node *node)
+ {
+ return node->data;
+ }
+
+-inline void set_data(Node *node, Data *data)
++static inline void set_data(Node *node, Data *data)
+ {
+ if (data != node->data) {
+ if (node->data) free(node->data);
+@@ -98,7 +98,7 @@ inline void set_data(Node *node, Data *d
+ }
+ }
+
+-inline uint32_t key_hash(HTree *tree, Item* it)
++static inline uint32_t key_hash(HTree *tree, Item* it)
+ {
+ char buf[255];
+ int n = dc_decode(tree->dc, buf, it->key, KEYLENGTH(it));
+@@ -256,8 +256,7 @@ static void merge_node(HTree *tree, Node
+ for (i=0; i<BUCKET_SIZE; i++){
+ Data *data = get_data(child+i);
+ Item *it = data->head;
+- int count = (child+i)->count;
+- for (j=0; j < count; j++){
++ for (j=0; j < data->count; j++){
+ if (it->ver > 0) {
+ add_item(tree, node, it, key_hash(tree, it), false);
+ } // drop deleted items, ver < 0
+@@ -315,7 +314,7 @@ static Item* get_item_hash(HTree* tree,
+ return r;
+ }
+
+-inline int hex2int(char b)
++static inline int hex2int(char b)
+ {
+ if (('0'<=b && b<='9') || ('a'<=b && b<='f')) {
+ return (b>='a') ? (b-'a'+10) : (b-'0');
+@@ -690,7 +689,7 @@ void ht_destroy(HTree *tree)
+ free(tree);
+ }
+
+-inline uint32_t keyhash(const char *s, int len)
++static inline uint32_t keyhash(const char *s, int len)
+ {
+ return fnv1a(s, len);
+ }
diff --git a/databases/beansdb/pkg-descr b/databases/beansdb/pkg-descr
index 67b20a285ab8..2c9ebf024967 100644
--- a/databases/beansdb/pkg-descr
+++ b/databases/beansdb/pkg-descr
@@ -1,6 +1,6 @@
-BeansDB is a major amount of data for large, high-availability storage systems
-distributed KeyValue using HashTree and simplified version number to
-quickly synchronize to ensure consistency in the final (weak),
+BeansDB is a major amount of data for large, high-availability storage
+systems distributed KeyValue using HashTree and simplified version
+number to quickly synchronize to ensure consistency in the final (weak),
a simplified version of the Dynamo.
-WWW: http://code.google.com/p/beansdb/
+WWW: http://github.com/douban/beansdb/