aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-06-25 00:29:25 +0800
committeradamw <adamw@FreeBSD.org>2015-06-25 00:29:25 +0800
commit475635d0194c2a685c1d35cadcad286989448b70 (patch)
treee6273a1c16a31c1f575721d9eb86248e44b517d3 /databases
parenteda6af329925c510247b9af3b5b93dd8e3d6ed42 (diff)
downloadfreebsd-ports-gnome-475635d0194c2a685c1d35cadcad286989448b70.tar.gz
freebsd-ports-gnome-475635d0194c2a685c1d35cadcad286989448b70.tar.zst
freebsd-ports-gnome-475635d0194c2a685c1d35cadcad286989448b70.zip
Convert all p5-Test-use-ok dependencies to p5-Test-Simple, but only on
perl < 5.22. For www/p5-Catalyst-Controller-BindLex, change it from a BUILD/RUN depend to TEST, as it is only used for the test target, and bump PORTREVISION on that port.
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBICx-MapMaker/Makefile9
-rw-r--r--databases/p5-DBICx-TestDatabase/Makefile9
2 files changed, 14 insertions, 4 deletions
diff --git a/databases/p5-DBICx-MapMaker/Makefile b/databases/p5-DBICx-MapMaker/Makefile
index 311036c532b4..8267838a9ddf 100644
--- a/databases/p5-DBICx-MapMaker/Makefile
+++ b/databases/p5-DBICx-MapMaker/Makefile
@@ -16,9 +16,14 @@ RUN_DEPENDS= p5-Moose>=0.39:${PORTSDIR}/devel/p5-Moose
BUILD_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class \
p5-DBICx-TestDatabase>=0.02:${PORTSDIR}/databases/p5-DBICx-TestDatabase \
p5-Moose>=0.39:${PORTSDIR}/devel/p5-Moose
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBICx-TestDatabase/Makefile b/databases/p5-DBICx-TestDatabase/Makefile
index 18acd6478c1f..38b160c8e1b5 100644
--- a/databases/p5-DBICx-TestDatabase/Makefile
+++ b/databases/p5-DBICx-TestDatabase/Makefile
@@ -21,9 +21,14 @@ BUILD_DEPENDS= p5-DBIx-Class>=0.07005:${PORTSDIR}/databases/p5-DBIx-Class \
RUN_DEPENDS= p5-DBD-SQLite>=1.12:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator \
p5-File-Temp>0:${PORTSDIR}/devel/p5-File-Temp
-TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
USES= perl5
USE_PERL5= configure
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502200
+TEST_DEPENDS+= p5-Test-Simple>=1.001.014:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>