aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-04 04:23:13 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-04 04:23:13 +0800
commit523e2b5a83045124ac3bcc4c62d8838de6257e9b (patch)
treefb08278f32f6f89c8ce5d31b9c5104205961bc9d /databases
parent40e905e4b57127f3f6075661e706d538f3e1d841 (diff)
downloadfreebsd-ports-gnome-523e2b5a83045124ac3bcc4c62d8838de6257e9b.tar.gz
freebsd-ports-gnome-523e2b5a83045124ac3bcc4c62d8838de6257e9b.tar.zst
freebsd-ports-gnome-523e2b5a83045124ac3bcc4c62d8838de6257e9b.zip
- Add p5-Dancer-Plugin-Redis 0.02
Dancer::Plugin::Redis provides an easy way to obtain a connected Redis database handle by simply calling the 'redis' keyword within a Dancer application. WWW: http://search.cpan.org/dist/Dancer-Plugin-Redis/ PR: ports/160346 Submitted by: Grzegorz Blach <magik@roorback.net>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Dancer-Plugin-Redis/Makefile30
-rw-r--r--databases/p5-Dancer-Plugin-Redis/distinfo2
-rw-r--r--databases/p5-Dancer-Plugin-Redis/pkg-descr5
-rw-r--r--databases/p5-Dancer-Plugin-Redis/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b3b00220a18f..0b891d0fd9c2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -411,6 +411,7 @@
SUBDIR += p5-DWH_File
SUBDIR += p5-Dancer-Plugin-DBIC
SUBDIR += p5-Dancer-Plugin-Database
+ SUBDIR += p5-Dancer-Plugin-Redis
SUBDIR += p5-Dancer-Session-Memcached
SUBDIR += p5-Data-Page
SUBDIR += p5-Data-Pageset
diff --git a/databases/p5-Dancer-Plugin-Redis/Makefile b/databases/p5-Dancer-Plugin-Redis/Makefile
new file mode 100644
index 000000000000..9de7514aefec
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Redis/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Dancer-Plugin-Redis
+# Date created: 31 August 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-Redis
+PORTVERSION= 0.02
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CSCM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Redis database connector for Dancer
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
+ p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+RUN_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
+ p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Plugin::Redis.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Dancer-Plugin-Redis/distinfo b/databases/p5-Dancer-Plugin-Redis/distinfo
new file mode 100644
index 000000000000..d600c021838b
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Redis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Redis-0.02.tar.gz) = c24c08a50c4dfc87c3d92a3884696b23b2bed6cbcf882b943a77014d22228a2a
+SIZE (Dancer-Plugin-Redis-0.02.tar.gz) = 4621
diff --git a/databases/p5-Dancer-Plugin-Redis/pkg-descr b/databases/p5-Dancer-Plugin-Redis/pkg-descr
new file mode 100644
index 000000000000..96d13de21f60
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Redis/pkg-descr
@@ -0,0 +1,5 @@
+Dancer::Plugin::Redis provides an easy way to obtain a connected Redis
+database handle by simply calling the 'redis' keyword within a Dancer
+application.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-Redis/
diff --git a/databases/p5-Dancer-Plugin-Redis/pkg-plist b/databases/p5-Dancer-Plugin-Redis/pkg-plist
new file mode 100644
index 000000000000..cbbba56fd2f8
--- /dev/null
+++ b/databases/p5-Dancer-Plugin-Redis/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Dancer/Plugin/Redis.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Redis/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Redis
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer