aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-11-01 09:36:41 +0800
committerclsung <clsung@FreeBSD.org>2011-11-01 09:36:41 +0800
commit6affca2eefcfb3ffe005ee62fb85ee016c9a4cd2 (patch)
tree5494a2838d36bac7a8fe18b16ea29ba6a8650e76 /databases
parent4dd7d65ff0753b93e9ccedc7052432ca89c3626c (diff)
downloadfreebsd-ports-gnome-6affca2eefcfb3ffe005ee62fb85ee016c9a4cd2.tar.gz
freebsd-ports-gnome-6affca2eefcfb3ffe005ee62fb85ee016c9a4cd2.tar.zst
freebsd-ports-gnome-6affca2eefcfb3ffe005ee62fb85ee016c9a4cd2.zip
- Fixed reconnect function
- In databases/p5-Redis method ping() has changed behavior, now in disconnect state, it return false instead of throwing exception. http://api.metacpan.org/source/MELO/Redis-1.904/Changes This cause p5-Dancer-Plugin-Redis to crash on reconnect. And p5-Dancer-Plugin-Redis wasn't updated upstream yet, so I attached a lite patch for fix this crash. - bump PORTREVISION PR: ports/161925 Submitted by: maintainer (Grzegorz Blach)
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Dancer-Plugin-Redis/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/databases/p5-Dancer-Plugin-Redis/Makefile b/databases/p5-Dancer-Plugin-Redis/Makefile
index 9de7514aefec..abab2c558c96 100644
--- a/databases/p5-Dancer-Plugin-Redis/Makefile
+++ b/databases/p5-Dancer-Plugin-Redis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Dancer-Plugin-Redis
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CSCM
@@ -19,12 +20,17 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
- p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+ p5-Redis>=1.902:${PORTSDIR}/databases/p5-Redis
RUN_DEPENDS= p5-Dancer>=1.1750:${PORTSDIR}/www/p5-Dancer \
- p5-Redis>=0:${PORTSDIR}/databases/p5-Redis
+ p5-Redis>=1.902:${PORTSDIR}/databases/p5-Redis
PERL_CONFIGURE= yes
MAN3= Dancer::Plugin::Redis.3
+post-patch:
+ @${REINPLACE_CMD} -i'' -e \
+ 's/_check_connection($$handle->{dbh})/$$handle->{dbh}->ping/' \
+ ${WRKSRC}/lib/Dancer/Plugin/Redis.pm
+
.include <bsd.port.mk>