aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-08-24 04:47:36 +0800
committerolgeni <olgeni@FreeBSD.org>2002-08-24 04:47:36 +0800
commit7fed5802d618acfd17b1c3f4dc87656f8ecddd12 (patch)
tree31e5c3ea72ecff0ff7143a14d2703fe227e1c65b /databases
parent83601852188844a9fcb67da612c843a0abaac7fc (diff)
downloadfreebsd-ports-gnome-7fed5802d618acfd17b1c3f4dc87656f8ecddd12.tar.gz
freebsd-ports-gnome-7fed5802d618acfd17b1c3f4dc87656f8ecddd12.tar.zst
freebsd-ports-gnome-7fed5802d618acfd17b1c3f4dc87656f8ecddd12.zip
Add postgresql_autodoc, an automatic documentation generator for postgresql.
Supports output in HTML, GraphViz, SGML DocBook and DIA formats.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql_autodoc/Makefile31
-rw-r--r--databases/postgresql_autodoc/distinfo1
-rw-r--r--databases/postgresql_autodoc/pkg-comment1
-rw-r--r--databases/postgresql_autodoc/pkg-descr4
-rw-r--r--databases/postgresql_autodoc/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 2038ce7ed7ac..43f9c648c402 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -119,6 +119,7 @@
SUBDIR += postgresql-pltcl
SUBDIR += postgresql-tcltk
SUBDIR += postgresql7
+ SUBDIR += postgresql_autodoc
SUBDIR += pxtools
SUBDIR += py-MySQL
SUBDIR += py-MySQLdb
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
new file mode 100644
index 000000000000..37d7886443b1
--- /dev/null
+++ b/databases/postgresql_autodoc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: postgresql_autodoc
+# Date created: Fri Aug 23 22:22:36 CEST 2002
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql_autodoc
+PORTVERSION= 0.99
+CATEGORIES= databases
+MASTER_SITES= http://www.rbt.ca/autodoc/
+DISTNAME= postgresql_autodoc_${PORTVERSION}
+
+MAINTAINER= olgeni@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+
+USE_REINPLACE= yes
+USE_PERL5= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/local/bin/perl,${PERL},g" ${WRKSRC}/postgresql_autodoc.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/postgresql_autodoc.pl ${PREFIX}/bin/postgresql_autodoc
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql_autodoc/distinfo b/databases/postgresql_autodoc/distinfo
new file mode 100644
index 000000000000..56452a2eabbe
--- /dev/null
+++ b/databases/postgresql_autodoc/distinfo
@@ -0,0 +1 @@
+MD5 (postgresql_autodoc_0.99.tar.gz) = aa999ce12331639fb27ccbe84b93c912
diff --git a/databases/postgresql_autodoc/pkg-comment b/databases/postgresql_autodoc/pkg-comment
new file mode 100644
index 000000000000..95d1c8a9b34a
--- /dev/null
+++ b/databases/postgresql_autodoc/pkg-comment
@@ -0,0 +1 @@
+Automatic documentation generator for postgresql databases
diff --git a/databases/postgresql_autodoc/pkg-descr b/databases/postgresql_autodoc/pkg-descr
new file mode 100644
index 000000000000..0d336e8ef569
--- /dev/null
+++ b/databases/postgresql_autodoc/pkg-descr
@@ -0,0 +1,4 @@
+Automatic documentation generator for postgresql databases.
+It supports output in HTML, GraphViz, SGML DocBook and DIA formats.
+
+WWW: http://www.rbt.ca/autodoc.html
diff --git a/databases/postgresql_autodoc/pkg-plist b/databases/postgresql_autodoc/pkg-plist
new file mode 100644
index 000000000000..2e6b9717b149
--- /dev/null
+++ b/databases/postgresql_autodoc/pkg-plist
@@ -0,0 +1 @@
+bin/postgresql_autodoc