aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-10 01:26:45 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-10 01:26:45 +0800
commit89ce105b80d55e86ab221cd97a9daf0eeaf74d24 (patch)
treec8c640ed43499b5c73784c4bd4bd015c1d4f05df /databases
parent0bff0126412a490b408691e212e367968e7e5285 (diff)
downloadfreebsd-ports-gnome-89ce105b80d55e86ab221cd97a9daf0eeaf74d24.tar.gz
freebsd-ports-gnome-89ce105b80d55e86ab221cd97a9daf0eeaf74d24.tar.zst
freebsd-ports-gnome-89ce105b80d55e86ab221cd97a9daf0eeaf74d24.zip
- patch to resolve THRIFT-1487 issue
PR: ports/163946 Approved by: gabor (mentor, implicit)
Diffstat (limited to 'databases')
-rw-r--r--databases/php5-pdo_cassandra/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/databases/php5-pdo_cassandra/Makefile b/databases/php5-pdo_cassandra/Makefile
index 608bf82725a1..72cbbd2cf0a8 100644
--- a/databases/php5-pdo_cassandra/Makefile
+++ b/databases/php5-pdo_cassandra/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdo_cassandra
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= https://github.com/${GITHUB_USER}/php-${PORTNAME}/tarball/${GITREVISION}/
PKGNAMEPREFIX= php5-
@@ -29,5 +30,13 @@ USE_PHP= pdo
USE_PHPEXT= yes
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=4 52
+THRIFT_CMD= ${LOCALBASE}/bin/thrift
+
+post-configure:
+ thrift_version=`${THRIFT_CMD} -version | ${AWK} '{print $$3}'`; \
+ if [ "$$thrift_version" = "0.8.0" ]; then \
+ ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.h; \
+ ${REINPLACE_CMD} 's/\([^:]\)apache::thrift/\1 ::apache::thrift/g' ${WRKSRC}/gen-cpp/Cassandra.cpp; \
+ fi
.include <bsd.port.mk>