aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-07-07 08:15:47 +0800
committerjgh <jgh@FreeBSD.org>2013-07-07 08:15:47 +0800
commit8dbf713038fa26231c40ee53693248e8ec17a4d9 (patch)
treea02701e350da7138f8932579a7323e96fb5738bb /databases
parent0a5b568bc6cac86dd2949d7579a28f481b660413 (diff)
downloadfreebsd-ports-gnome-8dbf713038fa26231c40ee53693248e8ec17a4d9.tar.gz
freebsd-ports-gnome-8dbf713038fa26231c40ee53693248e8ec17a4d9.tar.zst
freebsd-ports-gnome-8dbf713038fa26231c40ee53693248e8ec17a4d9.zip
- convert from USE_GMAKE to USES=gmake
- trim historical headers With hat: pgsql@
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-libpgeasy/Makefile8
-rw-r--r--databases/postgresql-libpq++/Makefile8
-rw-r--r--databases/postgresql-libpqxx/Makefile2
-rw-r--r--databases/postgresql-plproxy/Makefile3
-rw-r--r--databases/postgresql84-server/Makefile6
-rw-r--r--databases/postgresql91-server/Makefile6
-rw-r--r--databases/postgresql92-server/Makefile6
7 files changed, 12 insertions, 27 deletions
diff --git a/databases/postgresql-libpgeasy/Makefile b/databases/postgresql-libpgeasy/Makefile
index cd015e98f9bf..d19b99d1e7b5 100644
--- a/databases/postgresql-libpgeasy/Makefile
+++ b/databases/postgresql-libpgeasy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PostgreSQL library pgeasy
-# Date created: October 24st, 2004
-# Whom: Palle Girgensohn <girgen@pingpong.net>
-#
+# Created by: Palle Girgensohn <girgen@pingpong.net>
# $FreeBSD$
-#
PKGNAMEPREFIX= postgresql-
PORTNAME= libpgeasy
@@ -19,7 +15,7 @@ COMMENT= An easy-to-use C interface to PostgreSQL
USE_AUTOTOOLS= libtool
USE_PGSQL= YES
-USE_GMAKE= YES
+USES= gmake
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
DOCSDIR= ${PREFIX}/share/doc/postgresql/${PORTNAME}
diff --git a/databases/postgresql-libpq++/Makefile b/databases/postgresql-libpq++/Makefile
index d46b59a556d5..7a099a608a61 100644
--- a/databases/postgresql-libpq++/Makefile
+++ b/databases/postgresql-libpq++/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PostgreSQL Pgaccess
-# Date created: December 1st, 2002
-# Whom: Palle Girgensohn <girgen@pingpong.net>
-#
+# Created by: Palle Girgensohn <girgen@pingpong.net>
# $FreeBSD$
-#
PORTNAME= libpq++
PORTVERSION= 4.0
@@ -18,7 +14,7 @@ MAINTAINER= pgsql@FreeBSD.org
COMMENT= C++ interface for PostgreSQL
USE_PGSQL= YES
-USE_GMAKE= YES
+USES= gmake
USE_LDCONFIG= YES
post-patch:
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 23dbfdd57025..9d738a5cceac 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -15,7 +15,7 @@ CONFLICTS= postgresql-libpqxx-3.*
PORTSCOUT= limit:^2\.
USE_PGSQL= yes
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
SOVERSION= 4
diff --git a/databases/postgresql-plproxy/Makefile b/databases/postgresql-plproxy/Makefile
index 0be6474b30bb..03e43c70dbe7 100644
--- a/databases/postgresql-plproxy/Makefile
+++ b/databases/postgresql-plproxy/Makefile
@@ -12,9 +12,8 @@ COMMENT= PL/Proxy - database partitioning system
LICENSE= BSD
-USES= bison
+USES= bison gmake
USE_PGSQL= yes
-USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
PORTSCOUT= site:http://pgfoundry.org/frs/?group_id=1000207
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 10392f78e143..82ec46a6b011 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -27,11 +27,9 @@ LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= yes
-USE_GMAKE= yes
+.if !defined(NO_BUILD)
+USES+= gmake
GNU_CONFIGURE= yes
-.if defined(NO_BUILD)
-.undef USE_GMAKE
-.undef GNU_CONFIGURE
.endif
PG_USER= pgsql
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 04c0d746c666..d84a1e28fb3b 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -32,11 +32,9 @@ LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= yes
-USE_GMAKE= yes
+.if !defined(NO_BUILD)
+USES+= gmake
GNU_CONFIGURE= yes
-.if defined(NO_BUILD)
-.undef USE_GMAKE
-.undef GNU_CONFIGURE
.endif
PG_USER= pgsql
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 666b62cad84b..904286a3e20f 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -32,11 +32,9 @@ LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= yes
-USE_GMAKE= yes
+.if !defined(NO_BUILD)
+USES+= gmake
GNU_CONFIGURE= yes
-.if defined(NO_BUILD)
-.undef USE_GMAKE
-.undef GNU_CONFIGURE
.endif
PG_USER= pgsql