aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2005-05-17 23:50:37 +0800
committerfjoe <fjoe@FreeBSD.org>2005-05-17 23:50:37 +0800
commit9191132cb3564c50011ff7a19505ebfc20127620 (patch)
tree43ca661c48df227ff0d45d086f25094959473a97 /databases
parente92e3422215f9b5bb0165d087db4aa67d9a7f4af (diff)
downloadfreebsd-ports-gnome-9191132cb3564c50011ff7a19505ebfc20127620.tar.gz
freebsd-ports-gnome-9191132cb3564c50011ff7a19505ebfc20127620.tar.zst
freebsd-ports-gnome-9191132cb3564c50011ff7a19505ebfc20127620.zip
- Fix build with wxgtk 2.6.0
- Bump PORTREVISION Submitted by: Yuri Bushmelev
Diffstat (limited to 'databases')
-rw-r--r--databases/pgadmin3-12/Makefile2
-rw-r--r--databases/pgadmin3-12/files/patch-configure30
-rw-r--r--databases/pgadmin3/Makefile2
-rw-r--r--databases/pgadmin3/files/patch-configure30
4 files changed, 46 insertions, 18 deletions
diff --git a/databases/pgadmin3-12/Makefile b/databases/pgadmin3-12/Makefile
index 5c28ed60ae70..8c6c4dd3a9af 100644
--- a/databases/pgadmin3-12/Makefile
+++ b/databases/pgadmin3-12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pgadmin3
PORTVERSION= 1.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= pgadmin3/release/v${PORTVERSION}/src
diff --git a/databases/pgadmin3-12/files/patch-configure b/databases/pgadmin3-12/files/patch-configure
index 18af8abfe59d..0a8db47b2dfe 100644
--- a/databases/pgadmin3-12/files/patch-configure
+++ b/databases/pgadmin3-12/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Tue Nov 30 02:09:55 2004
-+++ configure Fri May 6 00:59:54 2005
++++ configure Tue May 17 22:46:56 2005
@@ -4996,6 +4996,9 @@
# Which version of wxWindows is this?
WX_VERSION=`${WX_CONFIG} --version`
@@ -10,14 +10,28 @@
2.5*)
WX_VERSION="2.5"
;;
-@@ -5173,6 +5176,10 @@
- ;;
- *wx_gtk2u_core*)
+@@ -5175,6 +5178,10 @@
LIBS="$LIBS -lwx_gtk2u_stc-${WX_VERSION}"
-+ LIBS="$LIBS $WX_NEW_LDFLAGS"
-+ ;;
-+ *wx_gtk2_core*)
-+ LIBS="$LIBS -lwx_gtk2_stc-${WX_VERSION}"
LIBS="$LIBS $WX_NEW_LDFLAGS"
;;
++ *wx_gtk2_core*)
++ LIBS="$LIBS -lwx_gtk2_stc-${WX_VERSION}"
++ LIBS="$LIBS $WX_NEW_LDFLAGS"
++ ;;
*wx_gtkud-*)
+ LIBS="$LIBS -lwx_gtkud_stc-${WX_VERSION}"
+ LIBS="$LIBS $WX_NEW_LDFLAGS"
+@@ -5214,11 +5221,11 @@
+ ;;
+ esac
+ wx_wx_h="yes"
+- if test ! -f "${WX_HOME}/include/wx-2.5/wx/version.h"
++ if test ! -f "${WX_HOME}/include/wx-${WX_VERSION}/wx/version.h"
+ then
+ wx_wx_h="no"
+ fi
+- if test ! -f "${WX_HOME}/include/wx-2.5/wx/stc/stc.h"
++ if test ! -f "${WX_HOME}/include/wx-${WX_VERSION}/wx/stc/stc.h"
+ then
+ { { echo "$as_me:$LINENO: error: you need to install the stc package from wxWindows/contrib/src/stc" >&5
+ echo "$as_me: error: you need to install the stc package from wxWindows/contrib/src/stc" >&2;}
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index 5c28ed60ae70..8c6c4dd3a9af 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pgadmin3
PORTVERSION= 1.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= pgadmin3/release/v${PORTVERSION}/src
diff --git a/databases/pgadmin3/files/patch-configure b/databases/pgadmin3/files/patch-configure
index 18af8abfe59d..0a8db47b2dfe 100644
--- a/databases/pgadmin3/files/patch-configure
+++ b/databases/pgadmin3/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Tue Nov 30 02:09:55 2004
-+++ configure Fri May 6 00:59:54 2005
++++ configure Tue May 17 22:46:56 2005
@@ -4996,6 +4996,9 @@
# Which version of wxWindows is this?
WX_VERSION=`${WX_CONFIG} --version`
@@ -10,14 +10,28 @@
2.5*)
WX_VERSION="2.5"
;;
-@@ -5173,6 +5176,10 @@
- ;;
- *wx_gtk2u_core*)
+@@ -5175,6 +5178,10 @@
LIBS="$LIBS -lwx_gtk2u_stc-${WX_VERSION}"
-+ LIBS="$LIBS $WX_NEW_LDFLAGS"
-+ ;;
-+ *wx_gtk2_core*)
-+ LIBS="$LIBS -lwx_gtk2_stc-${WX_VERSION}"
LIBS="$LIBS $WX_NEW_LDFLAGS"
;;
++ *wx_gtk2_core*)
++ LIBS="$LIBS -lwx_gtk2_stc-${WX_VERSION}"
++ LIBS="$LIBS $WX_NEW_LDFLAGS"
++ ;;
*wx_gtkud-*)
+ LIBS="$LIBS -lwx_gtkud_stc-${WX_VERSION}"
+ LIBS="$LIBS $WX_NEW_LDFLAGS"
+@@ -5214,11 +5221,11 @@
+ ;;
+ esac
+ wx_wx_h="yes"
+- if test ! -f "${WX_HOME}/include/wx-2.5/wx/version.h"
++ if test ! -f "${WX_HOME}/include/wx-${WX_VERSION}/wx/version.h"
+ then
+ wx_wx_h="no"
+ fi
+- if test ! -f "${WX_HOME}/include/wx-2.5/wx/stc/stc.h"
++ if test ! -f "${WX_HOME}/include/wx-${WX_VERSION}/wx/stc/stc.h"
+ then
+ { { echo "$as_me:$LINENO: error: you need to install the stc package from wxWindows/contrib/src/stc" >&5
+ echo "$as_me: error: you need to install the stc package from wxWindows/contrib/src/stc" >&2;}