aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-04-16 11:29:40 +0800
committermnag <mnag@FreeBSD.org>2006-04-16 11:29:40 +0800
commit9818e0b20588b9a30ccf3a6cdf26e61c46060fba (patch)
tree6f254c36f7c9bcb9f5083334c605c0db915df3f5 /databases
parentcb936c8ed1d0ecf88e6281d478b0467b460698b1 (diff)
downloadfreebsd-ports-gnome-9818e0b20588b9a30ccf3a6cdf26e61c46060fba.tar.gz
freebsd-ports-gnome-9818e0b20588b9a30ccf3a6cdf26e61c46060fba.tar.zst
freebsd-ports-gnome-9818e0b20588b9a30ccf3a6cdf26e61c46060fba.zip
- Update to 3.3.5
- Teach sqlite{,3}.pc to use ${PTHREAD_LIBS} when select PTHREAD OPTIONS. - Building docs via ALL_TARGET instead of post-build
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile18
-rw-r--r--databases/sqlite3/distinfo6
-rw-r--r--databases/sqlite34/Makefile18
-rw-r--r--databases/sqlite34/distinfo6
4 files changed, 22 insertions, 26 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 8bbb829c6863..150aaeb15964 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sqlite
-PORTVERSION= 3.3.4
-PORTREVISION= 1
+PORTVERSION= 3.3.5
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
@@ -18,13 +17,12 @@ COMMENT= An SQL database engine in a C library w/ Tcl wrapper
USE_GMAKE= YES
USE_GNOME= pkgconfig
USE_AUTOTOOLS= libtool:15
+USE_DOS2UNIX= *.pc.in
INSTALLS_SHLIB= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
-
DOCSDIR= ${PREFIX}/share/doc/sqlite3
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite3
@@ -60,12 +58,18 @@ CONFIGURE_ARGS+= --enable-debug
.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
BUILD_DEPENDS+= tclsh${TCL_V}:${PORTSDIR}/lang/tcl${TCL_V:S/.//}
+ALL_TARGET= all doc
PORTDOCS= *
.endif
post-patch:
+.if defined(WITH_THREADS)
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e "s|(Libs:.*)|\1 ${PTHREAD_LIBS}|" \
+ -e "s|(Cflags:.*)|\1 ${PTHREAD_CFLAGS}|" \
+ ${WRKSRC}/sqlite.pc.in ${WRKSRC}/sqlite3.pc.in
+.endif
@${REINPLACE_CMD} -e "s|tclsh \$$(TOP)|\$$(TCLSH) \$$(TOP)|g" \
-e "s|./libtool|${LIBTOOL}|g" \
-e "s|\$${HAVE_TCL:1=tcl_install}||" \
@@ -75,12 +79,6 @@ post-patch:
@${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_V:S/.//}\"" \
>> ${WRKSRC}/freebsd.hints
-post-build:
-.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
- @${ECHO_MSG} "===> Building docs"
- @(cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} doc)
-.endif
-
post-install:
.if defined(WITH_TCLWRAPPER)
@${MKDIR} ${PREFIX}/lib/sqlite
diff --git a/databases/sqlite3/distinfo b/databases/sqlite3/distinfo
index 51919e474435..57843f46782a 100644
--- a/databases/sqlite3/distinfo
+++ b/databases/sqlite3/distinfo
@@ -1,3 +1,3 @@
-MD5 (sqlite-3.3.4.tar.gz) = e31b390c294c0ea093f0bed3353fdff2
-SHA256 (sqlite-3.3.4.tar.gz) = e61f85a18443cad333257f8d8fd4c211a4c4ffd9bf66b36c4050fa7207f8898a
-SIZE (sqlite-3.3.4.tar.gz) = 1644139
+MD5 (sqlite-3.3.5.tar.gz) = dd2a7b6f2a07a4403a0b5e17e8ed5b88
+SHA256 (sqlite-3.3.5.tar.gz) = e81d1176960a14459f9ff492b2c4fb1e2b55d0b2c82fd225dbc37afd02334256
+SIZE (sqlite-3.3.5.tar.gz) = 1651536
diff --git a/databases/sqlite34/Makefile b/databases/sqlite34/Makefile
index 8bbb829c6863..150aaeb15964 100644
--- a/databases/sqlite34/Makefile
+++ b/databases/sqlite34/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sqlite
-PORTVERSION= 3.3.4
-PORTREVISION= 1
+PORTVERSION= 3.3.5
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
@@ -18,13 +17,12 @@ COMMENT= An SQL database engine in a C library w/ Tcl wrapper
USE_GMAKE= YES
USE_GNOME= pkgconfig
USE_AUTOTOOLS= libtool:15
+USE_DOS2UNIX= *.pc.in
INSTALLS_SHLIB= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
-
DOCSDIR= ${PREFIX}/share/doc/sqlite3
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite3
@@ -60,12 +58,18 @@ CONFIGURE_ARGS+= --enable-debug
.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
BUILD_DEPENDS+= tclsh${TCL_V}:${PORTSDIR}/lang/tcl${TCL_V:S/.//}
+ALL_TARGET= all doc
PORTDOCS= *
.endif
post-patch:
+.if defined(WITH_THREADS)
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e "s|(Libs:.*)|\1 ${PTHREAD_LIBS}|" \
+ -e "s|(Cflags:.*)|\1 ${PTHREAD_CFLAGS}|" \
+ ${WRKSRC}/sqlite.pc.in ${WRKSRC}/sqlite3.pc.in
+.endif
@${REINPLACE_CMD} -e "s|tclsh \$$(TOP)|\$$(TCLSH) \$$(TOP)|g" \
-e "s|./libtool|${LIBTOOL}|g" \
-e "s|\$${HAVE_TCL:1=tcl_install}||" \
@@ -75,12 +79,6 @@ post-patch:
@${ECHO} "config_TARGET_TCL_LIBS=\"-L${PREFIX}/lib -ltcl${TCL_V:S/.//}\"" \
>> ${WRKSRC}/freebsd.hints
-post-build:
-.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
- @${ECHO_MSG} "===> Building docs"
- @(cd ${WRKSRC} && ${GMAKE} ${MAKE_ARGS} doc)
-.endif
-
post-install:
.if defined(WITH_TCLWRAPPER)
@${MKDIR} ${PREFIX}/lib/sqlite
diff --git a/databases/sqlite34/distinfo b/databases/sqlite34/distinfo
index 51919e474435..57843f46782a 100644
--- a/databases/sqlite34/distinfo
+++ b/databases/sqlite34/distinfo
@@ -1,3 +1,3 @@
-MD5 (sqlite-3.3.4.tar.gz) = e31b390c294c0ea093f0bed3353fdff2
-SHA256 (sqlite-3.3.4.tar.gz) = e61f85a18443cad333257f8d8fd4c211a4c4ffd9bf66b36c4050fa7207f8898a
-SIZE (sqlite-3.3.4.tar.gz) = 1644139
+MD5 (sqlite-3.3.5.tar.gz) = dd2a7b6f2a07a4403a0b5e17e8ed5b88
+SHA256 (sqlite-3.3.5.tar.gz) = e81d1176960a14459f9ff492b2c4fb1e2b55d0b2c82fd225dbc37afd02334256
+SIZE (sqlite-3.3.5.tar.gz) = 1651536