aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-14 01:14:53 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-14 01:14:53 +0800
commita449e66640f4e67f3d5033c093a6215fcc21316f (patch)
treedb7d60e9baca3e8f203bee4b35e80db32ed1fe56 /databases
parented34fae3a7e3b290ef9af0be0e39c448dfdc8f83 (diff)
downloadfreebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.tar.gz
freebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.tar.zst
freebsd-ports-gnome-a449e66640f4e67f3d5033c093a6215fcc21316f.zip
- Fix build after iconv change [1]
- Fix build with clang/libc++ ([2] for graphics/ipe) While here for databases/spatialite: - Trim Makefile headers - Remove check for unsupported FreeBSD versions Submitted by: marino [1] Reported by: swills, antoine [1] Submitted by: bsam [2] Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'databases')
-rw-r--r--databases/spatialite/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 6e60f64a1553..7e1e3339eee6 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spatialite
-# Date created: 11 July 2008
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= spatialite
PORTVERSION= 3.0.1
@@ -22,12 +18,11 @@ LIB_DEPENDS= geos_c.9:${PORTSDIR}/graphics/geos \
EXTRACT_SUFX = .tar.gz
WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_SQLITE= yes
-USES= iconv
+USES= gmake iconv
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
@@ -40,10 +35,6 @@ post-patch:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-BROKEN= does not build
-.endif
-
.if ${ARCH} == "powerpc"
BROKEN= Does not compile on powerpc: invokes i386 assembler
.endif