aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-01-27 01:54:48 +0800
committerswills <swills@FreeBSD.org>2017-01-27 01:54:48 +0800
commita73c9db314133464035db21403391692517776ed (patch)
tree0490898a0edbaa79d7ac9dd0f038d961b4c70b4f /databases
parent09b4ee0496f7d3061f417392cd6a5ceb36288675 (diff)
downloadfreebsd-ports-gnome-a73c9db314133464035db21403391692517776ed.tar.gz
freebsd-ports-gnome-a73c9db314133464035db21403391692517776ed.tar.zst
freebsd-ports-gnome-a73c9db314133464035db21403391692517776ed.zip
databases/puppetdb: broken RUBY_VERSION regex
PR: 208814 Submitted by: Fabiano Sidler <fabianosidler@swissonline.ch> Approved by: Zach Leslie <freebsd@zleslie.info> (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/puppetdb/Makefile2
-rw-r--r--databases/puppetdb/files/patch-ext_master_lib_puppet_util_puppetdb_char__encoding.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/databases/puppetdb/Makefile b/databases/puppetdb/Makefile
index 15ac43caf27b..d99f8caa2020 100644
--- a/databases/puppetdb/Makefile
+++ b/databases/puppetdb/Makefile
@@ -2,7 +2,7 @@
PORTNAME= puppetdb
PORTVERSION= 2.3.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases java
MASTER_SITES= http://downloads.puppetlabs.com/puppetdb/
diff --git a/databases/puppetdb/files/patch-ext_master_lib_puppet_util_puppetdb_char__encoding.rb b/databases/puppetdb/files/patch-ext_master_lib_puppet_util_puppetdb_char__encoding.rb
new file mode 100644
index 000000000000..dc279d8aeb92
--- /dev/null
+++ b/databases/puppetdb/files/patch-ext_master_lib_puppet_util_puppetdb_char__encoding.rb
@@ -0,0 +1,11 @@
+--- ext/master/lib/puppet/util/puppetdb/char_encoding.rb.orig 2015-10-13 22:23:24 UTC
++++ ext/master/lib/puppet/util/puppetdb/char_encoding.rb
+@@ -33,7 +33,7 @@ module CharEncoding
+
+
+ def self.utf8_string(str)
+- if RUBY_VERSION =~ /1.8/
++ if RUBY_VERSION =~ /^1\.8/
+ # Ruby 1.8 doesn't have String#encode and related methods, and there
+ # appears to be a bug in iconv that will interpret some byte sequences
+ # as 6-byte characters. Thus, we are forced to resort to some unfortunate