aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2009-08-04 20:28:36 +0800
committerolgeni <olgeni@FreeBSD.org>2009-08-04 20:28:36 +0800
commitab1177f88adcc88ee524ff77fba89c67d124ce02 (patch)
treeefd447d4ffbea436b6f59b1a32e8c9df62d7655c /databases
parent63ad166e098be3e736bf17d279740ef75ac2c0ca (diff)
downloadfreebsd-ports-gnome-ab1177f88adcc88ee524ff77fba89c67d124ce02.tar.gz
freebsd-ports-gnome-ab1177f88adcc88ee524ff77fba89c67d124ce02.tar.zst
freebsd-ports-gnome-ab1177f88adcc88ee524ff77fba89c67d124ce02.zip
Reduce diff with ports/135096: USE_PGSQL and set IGNORE_WITH_PGSQL
to 84 (will be supported by slony1 1.2.17). PR: ports/135096 (partial) Approved by: maintainer
Diffstat (limited to 'databases')
-rw-r--r--databases/slony1/Makefile7
-rw-r--r--databases/slony1v2/Makefile7
2 files changed, 8 insertions, 6 deletions
diff --git a/databases/slony1/Makefile b/databases/slony1/Makefile
index 6de4d7a80805..1f68cc41285c 100644
--- a/databases/slony1/Makefile
+++ b/databases/slony1/Makefile
@@ -15,11 +15,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
-PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
-BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
+BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
@@ -31,6 +30,8 @@ OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+IGNORE_WITH_PGSQL= 84
+
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index 6de4d7a80805..1f68cc41285c 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -15,11 +15,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= vivek@khera.org
COMMENT= PostgreSQL master to multiple replicas replication system
-PGSQL_PORT= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-RUN_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
-BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PGSQL_PORT}
+BUILD_DEPENDS= ${LOCALBASE}/bin/postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
GNU_CONFIGURE= yes
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
@@ -31,6 +30,8 @@ OPTIONS= PERLTOOLS "Install perl configuration tools" Off
.include <bsd.port.pre.mk>
+IGNORE_WITH_PGSQL= 84
+
.if defined(WITH_PERLTOOLS)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perltools=${LOCALBASE}/sbin