aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-06-10 23:22:12 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-06-10 23:22:12 +0800
commitbb38e12279ada3011663a0f1353198d8864e1ef1 (patch)
tree9c0d61b46ea6b424c45130ff763a3f66363e24a1 /databases
parent30257ba2f38ca51fb4d16ccc0bee3fdb3978443b (diff)
downloadfreebsd-ports-gnome-bb38e12279ada3011663a0f1353198d8864e1ef1.tar.gz
freebsd-ports-gnome-bb38e12279ada3011663a0f1353198d8864e1ef1.tar.zst
freebsd-ports-gnome-bb38e12279ada3011663a0f1353198d8864e1ef1.zip
- Explain to user how to build if they have openssl installed. Another option
is to auto select OPENSSL and PORTSSL options but I stuck with letting the user make that decision. PR: 186566 Reported by: agifford@infowest.com
Diffstat (limited to 'databases')
-rw-r--r--databases/mariadb55-server/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/mariadb55-server/Makefile b/databases/mariadb55-server/Makefile
index 24948318e045..819dff575c60 100644
--- a/databases/mariadb55-server/Makefile
+++ b/databases/mariadb55-server/Makefile
@@ -83,9 +83,14 @@ CMAKE_ARGS+= -DWITH_JEMALLOC="system"
.endif
.if ${PORT_OPTIONS:MSSL}
+.if exists(${LOCALBASE}/include/openssl/opensslv.h)
+. if !${PORT_OPTIONS:MOPENSSL} || !${PORT_OPTIONS:MPORTSSL}
+IGNORE= security/openssl package is installed. To build this either select the OPENSSL and PORTSSL options or deinstall openssl
+. endif
+.endif
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
-.if empty(PORT_OPTIONS:MPORTSSL)
+.if !${PORT_OPTIONS:MPORTSSL}
WITH_OPENSSL_BASE= yes
.else
WITH_OPENSSL_PORT= yes