aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-09-20 02:20:19 +0800
committerosa <osa@FreeBSD.org>2012-09-20 02:20:19 +0800
commitbee1f359dac59c6cddedf7e813ced082cc724caf (patch)
tree698c62f077128e585ca7495bef2e0decf99f0a69 /databases
parent34edef7b2d8db59fac27f7aefeca7021c8ade483 (diff)
downloadfreebsd-ports-gnome-bee1f359dac59c6cddedf7e813ced082cc724caf.tar.gz
freebsd-ports-gnome-bee1f359dac59c6cddedf7e813ced082cc724caf.tar.zst
freebsd-ports-gnome-bee1f359dac59c6cddedf7e813ced082cc724caf.zip
Update from 2.6.0rc6 to 2.6.0rc7.
<ChangeLog> UPGRADE URGENCY: HIGH * [BUGFIX] Theoretical bug in ziplist fixed. * [BUGFIX] Better out of memory handling (Log produced in log file). * [BUGFIX] Incrementally flush RDB file on slave side while performing the first synchronization with the master. This makes Redis less blocking in environments where disk I/O is slow. * [BUGFIX] Don't crash with Lua's redis.call() without arguments. * [BUGFIX] Don't crash after a big number of Lua calls on 32 bit systems because of a failed assertion. * [BUGFIX] Fix SORT behaviour when called from scripting. * [BUGFIX] Adjust slave PING period accordingly to REDIS_HZ define. * [BUGFIX] BITCOUNT: fix crash on overflowing arguments. * [BUGFIX] Return an error when SELECT argument is not an integer. * [BUGFIX] Blocking operations on lists were completely reimplemented for correctness. Now blocking list ops and pushes originated from Lua scripts will play well together and will be replicated and transmitted to the AOF correctly. * [IMPROVED] Send async PING before starting replication to avoid blocking if master allows us to connect but it is actually not able to reply. * [IMPROVED] Support slave-priority for Redis Sentinel. * [IMPROVED] Hiredis library updated. </ChangeLog>
Diffstat (limited to 'databases')
-rw-r--r--databases/redis-devel/Makefile2
-rw-r--r--databases/redis-devel/distinfo4
-rw-r--r--databases/redis-devel/files/patch-src::replication.c10
3 files changed, 13 insertions, 3 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index ef436b858f38..950a29c469bc 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= redis
-DISTVERSION= 2.6.0-rc6
+DISTVERSION= 2.6.0-rc7
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -devel
diff --git a/databases/redis-devel/distinfo b/databases/redis-devel/distinfo
index 738fe5d63ff1..78338be92e56 100644
--- a/databases/redis-devel/distinfo
+++ b/databases/redis-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.6.0-rc6.tar.gz) = 0bc49799cc644bd849ca2a85d073fda6fd5e29a469969213a912e1e227000961
-SIZE (redis-2.6.0-rc6.tar.gz) = 967845
+SHA256 (redis-2.6.0-rc7.tar.gz) = 538e68479465b074497c1e76df70e40a61e6cfcb5e8f9dce5eaabc5448eedd43
+SIZE (redis-2.6.0-rc7.tar.gz) = 973045
diff --git a/databases/redis-devel/files/patch-src::replication.c b/databases/redis-devel/files/patch-src::replication.c
new file mode 100644
index 000000000000..3b99f53c2d6d
--- /dev/null
+++ b/databases/redis-devel/files/patch-src::replication.c
@@ -0,0 +1,10 @@
+--- src/replication.c.orig 2012-09-19 10:46:28.000000000 +0400
++++ src/replication.c 2012-09-19 10:47:01.000000000 +0400
+@@ -1,5 +1,7 @@
+ #include "redis.h"
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <fcntl.h>