aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-08 02:20:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-08 02:20:39 +0800
commitc8dd0801c79daa794caf2e13894534576260ea57 (patch)
treeb4b877c119d2447895cc4e35e44d9dc3525df28d /databases
parente52ed7388ccdf8ac7f47de4752ce6935310f850c (diff)
downloadfreebsd-ports-gnome-c8dd0801c79daa794caf2e13894534576260ea57.tar.gz
freebsd-ports-gnome-c8dd0801c79daa794caf2e13894534576260ea57.tar.zst
freebsd-ports-gnome-c8dd0801c79daa794caf2e13894534576260ea57.zip
- Remove deprecated PTHREAD_*
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-BDB/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/p5-BDB/Makefile b/databases/p5-BDB/Makefile
index 5095a79e2554..da35857fb26f 100644
--- a/databases/p5-BDB/Makefile
+++ b/databases/p5-BDB/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:1.801
CFLAGS+= -I${BDB_INCLUDE_DIR}
-LDFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -pthread
USE_BDB= 43+
USE_PERL5= configure
USES= perl5
@@ -26,6 +26,6 @@ USES= perl5
MAN3= BDB.3
post-patch:
- @${REINPLACE_CMD} -e '18 s|-lpthread -ldb|-l${BDB_LIB_NAME} ${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e '18 s|-lpthread -ldb|-l${BDB_LIB_NAME} -pthread|' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>