aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-02-12 04:31:53 +0800
committersobomax <sobomax@FreeBSD.org>2002-02-12 04:31:53 +0800
commitd15ec76ae06d938f7771b1b8c559818ca6bee97e (patch)
tree7e174dbd819a6270faf8aa2a5aff16252b071f2c /databases
parent3bf41f4cd6e3110b8fa2397664ef4b812cd3abbe (diff)
downloadfreebsd-ports-gnome-d15ec76ae06d938f7771b1b8c559818ca6bee97e.tar.gz
freebsd-ports-gnome-d15ec76ae06d938f7771b1b8c559818ca6bee97e.tar.zst
freebsd-ports-gnome-d15ec76ae06d938f7771b1b8c559818ca6bee97e.zip
Yet again unbroke gnomedb-fe on -current by supplying -pthread flag during
linking phase. Investigation is still underway, but it seems that we still need -pthread on 5-CURRENT in some cases (see recent thread on -hackers). Bump PORTREVISION.
Diffstat (limited to 'databases')
-rw-r--r--databases/gnome-db/Makefile3
-rw-r--r--databases/gnomedb/Makefile3
-rw-r--r--databases/gnomedb2/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index fa035088707d..190aafb7c354 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomedb
PORTVERSION= 0.2.95
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
@@ -22,7 +23,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+ LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/databases/gnomedb/Makefile b/databases/gnomedb/Makefile
index fa035088707d..190aafb7c354 100644
--- a/databases/gnomedb/Makefile
+++ b/databases/gnomedb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomedb
PORTVERSION= 0.2.95
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
@@ -22,7 +23,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+ LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/databases/gnomedb2/Makefile b/databases/gnomedb2/Makefile
index fa035088707d..190aafb7c354 100644
--- a/databases/gnomedb2/Makefile
+++ b/databases/gnomedb2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomedb
PORTVERSION= 0.2.95
+PORTREVISION= 1
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
@@ -22,7 +23,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+ LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}