aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2015-12-19 19:03:36 +0800
committermandree <mandree@FreeBSD.org>2015-12-19 19:03:36 +0800
commitd4c488bf144da3e520fc99b504d22e3c61400275 (patch)
tree41b86d4ebbd2dd1d73d835a0c083615db7327486 /databases
parent5294fb2a154959204f6557d5a5e411323035ad81 (diff)
downloadfreebsd-ports-gnome-d4c488bf144da3e520fc99b504d22e3c61400275.tar.gz
freebsd-ports-gnome-d4c488bf144da3e520fc99b504d22e3c61400275.tar.zst
freebsd-ports-gnome-d4c488bf144da3e520fc99b504d22e3c61400275.zip
Fix crash by using POSIX mutexes on all armv6* ARCHes not just armv6.
This is to fix illegal-instruction crashes on armv6hf. PR: 205001 Submitted by: dave@dogwood.com Reviewed by: mikael.urankar@gmail.com MFH: 2015Q4
Diffstat (limited to 'databases')
-rw-r--r--databases/db5/Makefile5
-rw-r--r--databases/db6/Makefile4
2 files changed, 6 insertions, 3 deletions
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 95187b664bc1..a323233c9ed3 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= db5
PORTVERSION= 5.3.28
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases java
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
@@ -39,8 +39,9 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH:Marmv6*}
# db5 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
+# also bug#205001
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db6/Makefile b/databases/db6/Makefile
index f5d648573d6f..09290072daff 100644
--- a/databases/db6/Makefile
+++ b/databases/db6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= db6
PORTVERSION= 6.1.19
+PORTREVISION= 1
CATEGORIES= databases java
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
@@ -40,8 +41,9 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH:Marmv6*}
# db6 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
+# and also bug #205001
CONFIGURE_ARGS+= --enable-posixmutexes
.endif