aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2013-05-30 20:51:11 +0800
committerculot <culot@FreeBSD.org>2013-05-30 20:51:11 +0800
commitd517f43fbe02affd9171a3b9ffd9833a334dc069 (patch)
tree246bcc4140e47ab09268ac654cb5c06427de8970 /databases
parentd05e3b71aac9f59e3cae110ce7d84f45e25e9d2a (diff)
downloadfreebsd-ports-gnome-d517f43fbe02affd9171a3b9ffd9833a334dc069.tar.gz
freebsd-ports-gnome-d517f43fbe02affd9171a3b9ffd9833a334dc069.tar.zst
freebsd-ports-gnome-d517f43fbe02affd9171a3b9ffd9833a334dc069.zip
SQL::Abstract::More Generates SQL from Perl datastructures. This is a
subclass of SQL::Abstract, fully compatible with the parent class, but it handles a few additional SQL constructs, and provides a different API with named parameters instead of positional parameters, so that various SQL fragments are more easily identified. This module was designed for the specific needs of DBIx::DataModel, but is published as a standalone distribution, because it may possibly be useful for other needs. WWW: http://search.cpan.org/dist/SQL-Abstract-More/ PR: ports/176883 Submitted by: Espen Tagestad <espen@tagestad.no>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-SQL-Abstract-More/Makefile26
-rw-r--r--databases/p5-SQL-Abstract-More/distinfo2
-rw-r--r--databases/p5-SQL-Abstract-More/pkg-descr11
-rw-r--r--databases/p5-SQL-Abstract-More/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9b182a03238b..a44f427cee27 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -465,6 +465,7 @@
SUBDIR += p5-Rose-DBx-Object-Renderer
SUBDIR += p5-SQL-Abstract
SUBDIR += p5-SQL-Abstract-Limit
+ SUBDIR += p5-SQL-Abstract-More
SUBDIR += p5-SQL-Abstract-Plugin-InsertMulti
SUBDIR += p5-SQL-Interp
SUBDIR += p5-SQL-Maker
diff --git a/databases/p5-SQL-Abstract-More/Makefile b/databases/p5-SQL-Abstract-More/Makefile
new file mode 100644
index 000000000000..eaf8ff210db5
--- /dev/null
+++ b/databases/p5-SQL-Abstract-More/Makefile
@@ -0,0 +1,26 @@
+# Created by: Espen Tagestad <espen@tagestad.no>
+# $FreeBSD$
+
+PORTNAME= SQL-Abstract-More
+PORTVERSION= 1.15
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= espen@tagestad.no
+COMMENT= Extension of SQL::Abstract with more constructs and more flexible API
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-MRO-Compat>0:${PORTSDIR}/devel/p5-MRO-Compat \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Scalar-Does>0:${PORTSDIR}/devel/p5-Scalar-Does \
+ p5-SQL-Abstract>=1.73:${PORTSDIR}/databases/p5-SQL-Abstract
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SQL::Abstract::More.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-SQL-Abstract-More/distinfo b/databases/p5-SQL-Abstract-More/distinfo
new file mode 100644
index 000000000000..76b4c0de6532
--- /dev/null
+++ b/databases/p5-SQL-Abstract-More/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SQL-Abstract-More-1.15.tar.gz) = 3468f4f0c549ea9f38416b43a4eb9f3f25ff3761791597f04f769086d2603dbc
+SIZE (SQL-Abstract-More-1.15.tar.gz) = 26954
diff --git a/databases/p5-SQL-Abstract-More/pkg-descr b/databases/p5-SQL-Abstract-More/pkg-descr
new file mode 100644
index 000000000000..b7c7ff0712e7
--- /dev/null
+++ b/databases/p5-SQL-Abstract-More/pkg-descr
@@ -0,0 +1,11 @@
+Generates SQL from Perl datastructures. This is a subclass of SQL::Abstract,
+fully compatible with the parent class, but it handles a few additional SQL
+constructs, and provides a different API with named parameters instead of
+positional parameters, so that various SQL fragments are more easily
+identified.
+
+This module was designed for the specific needs of DBIx::DataModel, but is
+published as a standalone distribution, because it may possibly be useful for
+other needs.
+
+WWW: http://search.cpan.org/dist/SQL-Abstract-More/
diff --git a/databases/p5-SQL-Abstract-More/pkg-plist b/databases/p5-SQL-Abstract-More/pkg-plist
new file mode 100644
index 000000000000..0ab87e07a075
--- /dev/null
+++ b/databases/p5-SQL-Abstract-More/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/SQL/Abstract/More.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SQL/Abstract/More/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SQL/Abstract/More