aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2005-07-26 06:15:13 +0800
committerlinimon <linimon@FreeBSD.org>2005-07-26 06:15:13 +0800
commitdc1595ca34424d36ced125fdc1e7cce24d95fd68 (patch)
treef4866323d2cdf964a087843a458187b0e3dc8709 /databases
parent5f721de497f8486dddafad84d42a51af3f496647 (diff)
downloadfreebsd-ports-gnome-dc1595ca34424d36ced125fdc1e7cce24d95fd68.tar.gz
freebsd-ports-gnome-dc1595ca34424d36ced125fdc1e7cce24d95fd68.tar.zst
freebsd-ports-gnome-dc1595ca34424d36ced125fdc1e7cce24d95fd68.zip
Allow portsmon and FreshPorts to understand that these ports which have
nonstandard Makefiles are actually slave ports. No response from: maintainer
Diffstat (limited to 'databases')
-rw-r--r--databases/ruby-dbd_interbase/Makefile3
-rw-r--r--databases/ruby-dbd_msql/Makefile3
-rw-r--r--databases/ruby-dbd_mysql/Makefile3
-rw-r--r--databases/ruby-dbd_odbc/Makefile3
-rw-r--r--databases/ruby-dbd_pg/Makefile3
-rw-r--r--databases/ruby-dbd_proxy/Makefile3
-rw-r--r--databases/ruby-dbd_sqlite/Makefile3
7 files changed, 21 insertions, 0 deletions
diff --git a/databases/ruby-dbd_interbase/Makefile b/databases/ruby-dbd_interbase/Makefile
index 4d968e220998..269ad11b835a 100644
--- a/databases/ruby-dbd_interbase/Makefile
+++ b/databases/ruby-dbd_interbase/Makefile
@@ -23,6 +23,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=lib/${PORTNAME}
diff --git a/databases/ruby-dbd_msql/Makefile b/databases/ruby-dbd_msql/Makefile
index c8e6de747572..6b9f8827e5a8 100644
--- a/databases/ruby-dbd_msql/Makefile
+++ b/databases/ruby-dbd_msql/Makefile
@@ -23,6 +23,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=lib/${PORTNAME}
diff --git a/databases/ruby-dbd_mysql/Makefile b/databases/ruby-dbd_mysql/Makefile
index db59291e2d7b..dd10373b5d7a 100644
--- a/databases/ruby-dbd_mysql/Makefile
+++ b/databases/ruby-dbd_mysql/Makefile
@@ -23,6 +23,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=lib/${PORTNAME}
diff --git a/databases/ruby-dbd_odbc/Makefile b/databases/ruby-dbd_odbc/Makefile
index 7fb20605a1fd..de6653884be0 100644
--- a/databases/ruby-dbd_odbc/Makefile
+++ b/databases/ruby-dbd_odbc/Makefile
@@ -23,6 +23,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=lib/${PORTNAME}
diff --git a/databases/ruby-dbd_pg/Makefile b/databases/ruby-dbd_pg/Makefile
index 82f1d777b02a..90de851dcc61 100644
--- a/databases/ruby-dbd_pg/Makefile
+++ b/databases/ruby-dbd_pg/Makefile
@@ -24,6 +24,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR} \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=lib/${PORTNAME}
diff --git a/databases/ruby-dbd_proxy/Makefile b/databases/ruby-dbd_proxy/Makefile
index b93c93857c85..c8695df0906f 100644
--- a/databases/ruby-dbd_proxy/Makefile
+++ b/databases/ruby-dbd_proxy/Makefile
@@ -23,6 +23,9 @@ USE_RUBY= yes
USE_RUBY_FEATURES= drb
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=bin/proxyserver,lib/${PORTNAME}
diff --git a/databases/ruby-dbd_sqlite/Makefile b/databases/ruby-dbd_sqlite/Makefile
index b274986ddedf..3153f1cfe1c3 100644
--- a/databases/ruby-dbd_sqlite/Makefile
+++ b/databases/ruby-dbd_sqlite/Makefile
@@ -24,6 +24,9 @@ RUN_DEPENDS= ${RUBY_SITELIBDIR}/dbi.rb:${RUBY_DBI_PORTDIR}
USE_RUBY= yes
USE_RUBY_SETUP= yes
+SLAVE_PORT= yes
+MASTER_PORT= databases/ruby-dbi
+
WRKSRC= ${RUBY_DBI_WRKSRC}
CONFIGURE_ARGS= --with=ext/${PORTNAME}