aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-11-01 08:48:30 +0800
committerseanc <seanc@FreeBSD.org>2003-11-01 08:48:30 +0800
commitddabe55659973df0b74af5fa9331f1cc1874053c (patch)
tree21412327d2f46dcce55c354d15ef863cf26ce3d7 /databases
parent1ee1174b80876a2604c9b380062549dcafe01b6b (diff)
downloadfreebsd-ports-gnome-ddabe55659973df0b74af5fa9331f1cc1874053c.tar.gz
freebsd-ports-gnome-ddabe55659973df0b74af5fa9331f1cc1874053c.tar.zst
freebsd-ports-gnome-ddabe55659973df0b74af5fa9331f1cc1874053c.zip
Add PostgreSQL support. Make MySQL support optional, but on by default.
Specifying WITHOUT_MYSQL removes MySQL support. WITH_POSTGRESQL speaks for itself. Port revision bump.
Diffstat (limited to 'databases')
-rw-r--r--databases/hk_classes/Makefile26
-rw-r--r--databases/hk_classes/pkg-plist9
2 files changed, 28 insertions, 7 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 72c1b587c6c3..51be272d8b78 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -6,6 +6,7 @@
PORTNAME= hk_classes
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hk-classes
@@ -15,13 +16,30 @@ COMMENT= "C++ Library for rapid development of database applications"
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+.if !defined(WITHOUT_MYSQL) || defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
- -with-mysql-dir=${LOCALBASE} \
- --with-mysql-incdir=${LOCALBASE}/include/mysql
+CONFIGURE_ARGS+= -with-mysql-dir=${LOCALBASE} \
+ --with-mysql-incdir=${LOCALBASE}/include/mysql
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if defined(WITH_POSTGRESQL)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+= --with-postgres-incdir=${LOCALBASE}/include/ \
+ --with-postgres-libdir=${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+PLIST_SUB+= POSTGRESQL=""
+.else
+PLIST_SUB+= POSTGRESQL="@comment "
+.endif
+
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
diff --git a/databases/hk_classes/pkg-plist b/databases/hk_classes/pkg-plist
index b68ff177181a..bc590dd4c222 100644
--- a/databases/hk_classes/pkg-plist
+++ b/databases/hk_classes/pkg-plist
@@ -37,9 +37,12 @@ include/hk_classes/hk_drivermanager.h
include/hk_classes/hk_colour.h
include/hk_classes/hk_font.h
include/hk_classes/hk_interpreter.h
-lib/hk_classes/drivers/libhk_mysqldriver.so.3
-lib/hk_classes/drivers/libhk_mysqldriver.so
-lib/hk_classes/drivers/libhk_mysqldriver.la
+%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.so.3
+%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.so
+%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.la
+%%POSTGRESQL%%lib/hk_classes/drivers/libhk_postgresdriver.so.0
+%%POSTGRESQL%%lib/hk_classes/drivers/libhk_postgresdriver.so
+%%POSTGRESQL%%lib/hk_classes/drivers/libhk_postgresdriver.la
lib/hk_classes/libhk_classes.so.5
lib/hk_classes/libhk_classes.la
lib/hk_classes/libhk_classes.so