aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
committerpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
commite3db8ee84c8bacf91265d9a1d659ed398630c37d (patch)
tree79ed9e5984a819f5a0bcea9bdfc3968804a6c2bf /databases
parent5bb45c428bbe01f1d4ca25e7ee7e6bc6d5cdc9a3 (diff)
downloadfreebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.gz
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.zst
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.zip
- Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MAKE_ENV
Diffstat (limited to 'databases')
-rw-r--r--databases/clip/Makefile1
-rw-r--r--databases/fastdb/Makefile2
-rw-r--r--databases/firebird-server/Makefile2
-rw-r--r--databases/firebird2-server/Makefile2
-rw-r--r--databases/firebird20-server/Makefile2
-rw-r--r--databases/py-MySQL/Makefile3
-rw-r--r--databases/py-PySQLite10/Makefile1
-rw-r--r--databases/py-PySQLite11/Makefile1
8 files changed, 4 insertions, 10 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index 87760afb0bd1..d9bb6b9685cc 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -114,7 +114,6 @@ MAKE_ENV= HOME="${WRKDIR}" \
PGINCDIR="${LOCALBASE}/include" \
OPT_CLIPLIBS="${OPT_CLIPLIBS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- LOCALBASE="${LOCALBASE}" \
WITH_IODBC="${WITH_IODBC}" \
CLIP_CONFIGURE_FLAGS="-l"
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 14331e28806c..8505abcc340e 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -18,8 +18,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
MAKE_ENV= OSTYPE="${OPSYS}" \
- PREFIX="${PREFIX}" \
- CXX="${CXX}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= makefile
diff --git a/databases/firebird-server/Makefile b/databases/firebird-server/Makefile
index f8ffe5bbd874..bf7c869a7dc5 100644
--- a/databases/firebird-server/Makefile
+++ b/databases/firebird-server/Makefile
@@ -80,7 +80,7 @@ PORTDOCS= *
.endif
.endif
-MAKE_ENV+= CC=${CC} CXX=${CXX} FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
+MAKE_ENV+= FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
.include <bsd.port.pre.mk>
diff --git a/databases/firebird2-server/Makefile b/databases/firebird2-server/Makefile
index 1efee944fb35..4ddaf7f72228 100644
--- a/databases/firebird2-server/Makefile
+++ b/databases/firebird2-server/Makefile
@@ -89,7 +89,7 @@ FB_DOCS_DIRS= sql.extensions license upgrade
.endif
.endif
-MAKE_ENV+= CC=${CC} CXX=${CXX} FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
+MAKE_ENV+= FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
post-extract:
@${RM} -rf ${WRKSRC}/extern/icu
diff --git a/databases/firebird20-server/Makefile b/databases/firebird20-server/Makefile
index 1efee944fb35..4ddaf7f72228 100644
--- a/databases/firebird20-server/Makefile
+++ b/databases/firebird20-server/Makefile
@@ -89,7 +89,7 @@ FB_DOCS_DIRS= sql.extensions license upgrade
.endif
.endif
-MAKE_ENV+= CC=${CC} CXX=${CXX} FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
+MAKE_ENV+= FIREBIRD_TMP="${WRKDIR}" FIREBIRD_LOCK="${WRKDIR}"
post-extract:
@${RM} -rf ${WRKSRC}/extern/icu
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index a37243adfb55..7283ccb40a14 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/MySQLmodule.so
USE_PYTHON= -2.4
-CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
-MAKE_ENV= ${CONFIGURE_ENV}
+MAKE_ENV= PYTHON="${PYTHON_CMD}"
.include <bsd.port.pre.mk>
diff --git a/databases/py-PySQLite10/Makefile b/databases/py-PySQLite10/Makefile
index b29bdb9d7011..fa8301b989ea 100644
--- a/databases/py-PySQLite10/Makefile
+++ b/databases/py-PySQLite10/Makefile
@@ -26,7 +26,6 @@ WRKSRC= ${WRKDIR}/pysqlite
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= pysqlite
-MAKE_ENV= LOCALBASE="${LOCALBASE}"
PORTDOCS= *
diff --git a/databases/py-PySQLite11/Makefile b/databases/py-PySQLite11/Makefile
index 5ef8052f89d9..3fb7e723bd14 100644
--- a/databases/py-PySQLite11/Makefile
+++ b/databases/py-PySQLite11/Makefile
@@ -24,7 +24,6 @@ NO_LATEST_LINK= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= pysqlite
-MAKE_ENV= LOCALBASE="${LOCALBASE}"
PORTDOCS= *