aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-02-20 04:35:39 +0800
committerohauer <ohauer@FreeBSD.org>2013-02-20 04:35:39 +0800
commitf25c47790090895e525f6fb83182f861cade2cd1 (patch)
tree3008cfc5833fec3a73976f635c00bc68af5d39a7 /databases
parent9ffde0cc1914dc43ab4915f63a7bb015a7a50e4a (diff)
downloadfreebsd-ports-gnome-f25c47790090895e525f6fb83182f861cade2cd1.tar.gz
freebsd-ports-gnome-f25c47790090895e525f6fb83182f861cade2cd1.tar.zst
freebsd-ports-gnome-f25c47790090895e525f6fb83182f861cade2cd1.zip
- new port postgis20
PostGIS adds support for geographic objects to the PostgreSQL object-relational database. In effect, PostGIS "spatially enables" the PostgreSQL server, allowing it to be used as a backend spatial database for geographic information systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS "Simple Features Specification for SQL" and has been certified as compliant with the "Types and Functions" profile. PostGIS development was started by Refractions Research as a project in open source spatial database technology. PostGIS is released under the GNU General Public License. PostGIS continues to be developed by a group of contributors led by a Project Steering Committee and new features continue to be added. WWW: http://www.postgis.org/ PR: 174620 Submitted by: Matthew Trisoline <matt.trisoline@intermedix.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgis20/Makefile80
-rw-r--r--databases/postgis20/distinfo2
-rw-r--r--databases/postgis20/pkg-descr13
-rw-r--r--databases/postgis20/pkg-install37
-rw-r--r--databases/postgis20/pkg-plist137
6 files changed, 270 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 2f9a5ad1c8f4..a482b2968d35 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -632,6 +632,7 @@
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
SUBDIR += postgis
+ SUBDIR += postgis20
SUBDIR += postgis-jdbc
SUBDIR += postgresql-jdbc
SUBDIR += postgresql-libpgeasy
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
new file mode 100644
index 000000000000..f073199b7514
--- /dev/null
+++ b/databases/postgis20/Makefile
@@ -0,0 +1,80 @@
+# $FreeBSD$
+
+PORTNAME= postgis
+PORTVERSION= 2.0.2
+CATEGORIES= databases geography
+MASTER_SITES= http://download.osgeo.org/postgis/source/
+
+MAINTAINER= matt.trisoline@intermedix.com
+COMMENT= Adds support for geographic objects to PostgreSQL databases
+
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj \
+ geos:${PORTSDIR}/graphics/geos \
+ json:${PORTSDIR}/devel/json-c
+RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+
+CONFLICTS= postgis-1.*
+LATEST_LINK= postgis20
+
+USE_GNOME= libxml2
+USE_PGSQL= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_PERL5_BUILD= yes
+
+OPTIONS_DEFINE= LOADERGUI RASTER TOPOLOGY
+OPTIONS_DEFAULT= TOPOLOGY
+
+LOADERGUI_DESC= Enable shp2pgsql-gui
+RASTER_DESC= Build with raster support
+TOPOLOGY_DESC= Build with topology support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLOADERGUI}
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --with-gui
+PLIST_SUB+= LOADERGUI=""
+.else
+CONFIGURE_ARGS+= --without-gui
+PLIST_SUB+= LOADERGUI="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MRASTER}
+.if ${OSVERSION} < 900033
+BROKEN= Raster suppport is broken on FreeBSD < 9.x
+.endif
+LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
+CONFIGURE_ARGS+= --with-raster --with-gdalconfig=${LOCALBASE}/bin/gdal-config
+PLIST_SUB+= RASTER=""
+.else
+CONFIGURE_ARGS+= --without-raster
+PLIST_SUB+= RASTER="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MTOPOLOGY}
+CONFIGURE_ARGS+= --with-topology
+PLIST_SUB+= TOPOLOGY=""
+.else
+CONFIGURE_ARGS+= --without-topology
+PLIST_SUB+= TOPOLOGY="@comment "
+.endif
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${GREP} -lR 'bin/bash' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e "s|/bin/bash|/bin/sh|"
+
+pre-configure:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install: .SILENT
+ ${MKDIR} ${DATADIR}/tiger_2010
+ (cd ${WRKSRC}/extras/tiger_geocoder/tiger_2010/ && ${COPYTREE_SHARE} \* ${DATADIR}/tiger_2010/ "! ( -name *\.orig -o -name *\.bak )" )
+ ${MKDIR} ${DATADIR}/utils
+ (cd ${WRKSRC}/utils/ && ${COPYTREE_SHARE} \* ${DATADIR}/utils/ "! ( -name *\.orig -o -name *\.bak )" )
+
+.include <bsd.port.mk>
diff --git a/databases/postgis20/distinfo b/databases/postgis20/distinfo
new file mode 100644
index 000000000000..f35a069fdb71
--- /dev/null
+++ b/databases/postgis20/distinfo
@@ -0,0 +1,2 @@
+SHA256 (postgis-2.0.2.tar.gz) = 57746d040080e624f3e81633a180d8a5fc16b0c035d94fe2c16306023ab1c391
+SIZE (postgis-2.0.2.tar.gz) = 5573652
diff --git a/databases/postgis20/pkg-descr b/databases/postgis20/pkg-descr
new file mode 100644
index 000000000000..34ad4355861a
--- /dev/null
+++ b/databases/postgis20/pkg-descr
@@ -0,0 +1,13 @@
+PostGIS adds support for geographic objects to the PostgreSQL object-relational
+database. In effect, PostGIS "spatially enables" the PostgreSQL server, allowing
+it to be used as a backend spatial database for geographic information systems
+(GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS follows the
+OpenGIS "Simple Features Specification for SQL" and has been certified as
+compliant with the "Types and Functions" profile.
+
+PostGIS development was started by Refractions Research as a project in open
+source spatial database technology. PostGIS is released under the GNU General
+Public License. PostGIS continues to be developed by a group of contributors led
+by a Project Steering Committee and new features continue to be added.
+
+WWW: http://www.postgis.org/
diff --git a/databases/postgis20/pkg-install b/databases/postgis20/pkg-install
new file mode 100644
index 000000000000..a61b132fcc5c
--- /dev/null
+++ b/databases/postgis20/pkg-install
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+msg(){
+ echo "
+ ======================= GEOS Support Notice ========================
+ In order to use the GEOS support, you may need to specially compile
+ your version of PostgreSQL to link the C++ runtime library.
+ To do this, invoke the PostgreSQL Makefile script this way:
+
+ on csh shell:
+
+ setenv LDFLAGS -lstdc++
+ make
+
+ on sh or bash shell:
+
+ export LDFLAGS=-lstdc++
+ make
+
+ The initial LDFLAGS variable is passed through to the Makefile and
+ adds the C++ library to the linking stage.
+
+ ====================================================================
+"
+if [ -n "${PACKAGE_BUILDING}" ]; then
+ sleep 10
+fi
+
+
+}
+
+case "$2" in
+ PRE-INSTALL)
+ msg ;;
+ MESSAGE)
+ msg ;;
+esac
diff --git a/databases/postgis20/pkg-plist b/databases/postgis20/pkg-plist
new file mode 100644
index 000000000000..49b539991276
--- /dev/null
+++ b/databases/postgis20/pkg-plist
@@ -0,0 +1,137 @@
+bin/pgsql2shp
+%%RASTER%%bin/raster2pgsql
+bin/shp2pgsql
+%%LOADERGUI%%bin/shp2pgsql-gui
+include/liblwgeom.h
+lib/postgresql/postgis-2.0.so
+%%RASTER%%lib/postgresql/rtpostgis-2.0.so
+lib/liblwgeom-2.0.2.so
+lib/liblwgeom.a
+lib/liblwgeom.la
+lib/liblwgeom.so
+%%DATADIR%%/tiger_2010/README
+%%DATADIR%%/tiger_2010/census_loader.sql
+%%DATADIR%%/tiger_2010/create_geocode.bat
+%%DATADIR%%/tiger_2010/create_geocode.sh
+%%DATADIR%%/tiger_2010/create_geocode.sql
+%%DATADIR%%/tiger_2010/geocode/rate_attributes.sql
+%%DATADIR%%/tiger_2010/geocode/geocode.sql
+%%DATADIR%%/tiger_2010/geocode/census_tracts_functions.sql
+%%DATADIR%%/tiger_2010/geocode/other_helper_functions.sql
+%%DATADIR%%/tiger_2010/geocode/geocode_address.sql
+%%DATADIR%%/tiger_2010/geocode/geocode_intersection.sql
+%%DATADIR%%/tiger_2010/geocode/includes_address.sql
+%%DATADIR%%/tiger_2010/geocode/geocode_location.sql
+%%DATADIR%%/tiger_2010/geocode/interpolate_from_address.sql
+%%DATADIR%%/tiger_2010/geocode/reverse_geocode.sql
+%%DATADIR%%/tiger_2010/legacy_import/tiger2008/import_tiger_shps.sh
+%%DATADIR%%/tiger_2010/normalize/location_extract_countysub_exact.sql
+%%DATADIR%%/tiger_2010/normalize/location_extract.sql
+%%DATADIR%%/tiger_2010/normalize/location_extract_countysub_fuzzy.sql
+%%DATADIR%%/tiger_2010/normalize/normalize_address.sql
+%%DATADIR%%/tiger_2010/normalize/count_words.sql
+%%DATADIR%%/tiger_2010/normalize/location_extract_place_exact.sql
+%%DATADIR%%/tiger_2010/normalize/state_extract.sql
+%%DATADIR%%/tiger_2010/normalize/end_soundex.sql
+%%DATADIR%%/tiger_2010/normalize/location_extract_place_fuzzy.sql
+%%DATADIR%%/tiger_2010/normalize/pprint_addy.sql
+%%DATADIR%%/tiger_2010/normalize/get_last_words.sql
+%%DATADIR%%/tiger_2010/regress/geocode_regress
+%%DATADIR%%/tiger_2010/regress/normalize_address_regress
+%%DATADIR%%/tiger_2010/regress/regress.sql
+%%DATADIR%%/tiger_2010/regress/reverse_geocode_regress.sql
+%%DATADIR%%/tiger_2010/regress/reverse_geocode_regress
+%%DATADIR%%/tiger_2010/regress/geocode_regress.sql
+%%DATADIR%%/tiger_2010/regress/normalize_address_regress.sql
+%%DATADIR%%/tiger_2010/tables/lookup_tables_2010.sql
+%%DATADIR%%/tiger_2010/tiger_loader.sql
+%%DATADIR%%/tiger_2010/topology/tiger_topology_loader.sql
+%%DATADIR%%/tiger_2010/topology/README
+%%DATADIR%%/tiger_2010/upgrade_geocode.sql
+%%DATADIR%%/tiger_2010/upgrade_geocoder.bat
+%%DATADIR%%/tiger_2010/upgrade_geocoder.sh
+%%DATADIR%%/tiger_2010/utility/utmzone.sql
+%%DATADIR%%/tiger_2010/utility/levenshtein_ignore_case.sql
+%%DATADIR%%/tiger_2010/utility/nullable_levenshtein.sql
+%%DATADIR%%/tiger_2010/utility/cull_null.sql
+%%DATADIR%%/utils/Makefile
+%%DATADIR%%/utils/Makefile.in
+%%DATADIR%%/utils/README
+%%DATADIR%%/utils/create_undef.pl
+%%DATADIR%%/utils/postgis_proc_upgrade.pl
+%%DATADIR%%/utils/postgis_restore.pl
+%%DATADIR%%/utils/postgis_restore.pl.in
+%%DATADIR%%/utils/profile_intersects.pl
+%%DATADIR%%/utils/read_scripts_version.pl
+%%DATADIR%%/utils/svn_repo_revision.pl
+%%DATADIR%%/utils/test_estimation.pl
+%%DATADIR%%/utils/test_geography_estimation.pl
+%%DATADIR%%/utils/test_geography_joinestimation.pl
+%%DATADIR%%/utils/test_joinestimation.pl
+%%DATADIR%%/utils/uninstall_script
+share/postgresql/contrib/postgis-2.0/postgis_comments.sql
+share/postgresql/contrib/postgis-2.0/raster_comments.sql
+share/postgresql/contrib/postgis-2.0/topology_comments.sql
+share/postgresql/contrib/postgis-2.0/spatial_ref_sys.sql
+share/postgresql/contrib/postgis-2.0/postgis.sql
+share/postgresql/contrib/postgis-2.0/uninstall_postgis.sql
+share/postgresql/contrib/postgis-2.0/postgis_upgrade_20_minor.sql
+share/postgresql/contrib/postgis-2.0/legacy.sql
+share/postgresql/contrib/postgis-2.0/uninstall_legacy.sql
+share/postgresql/contrib/postgis-2.0/legacy_minimal.sql
+share/postgresql/contrib/postgis-2.0/legacy_gist.sql
+%%RASTER%%share/postgresql/contrib/postgis-2.0/rtpostgis.sql
+%%RASTER%%share/postgresql/contrib/postgis-2.0/rtpostgis_upgrade_20_minor.sql
+%%RASTER%%share/postgresql/contrib/postgis-2.0/uninstall_rtpostgis.sql
+%%RASTER%%share/postgresql/contrib/postgis-2.0/rtpostgis_legacy.sql
+%%TOPOLOGY%%share/postgresql/contrib/postgis-2.0/topology.sql
+%%TOPOLOGY%%share/postgresql/contrib/postgis-2.0/topology_upgrade_20_minor.sql
+%%TOPOLOGY%%share/postgresql/contrib/postgis-2.0/uninstall_topology.sql
+share/postgresql/contrib/postgis-2.0/postgis_restore.pl
+share/postgresql/extension/postgis.control
+share/postgresql/extension/postgis--2.0.0alpha3--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0alpha4--2.0.2.sql
+share/postgresql/extension/postgis--2.0.1--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0alpha5--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0beta3--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0beta4--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0rc2--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0alpha6--2.0.2.sql
+share/postgresql/extension/postgis--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0alpha1--2.0.2.sql
+share/postgresql/extension/postgis--unpackaged--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0beta1--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0beta2--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0rc1--2.0.2.sql
+share/postgresql/extension/postgis--2.0.0alpha2--2.0.2.sql
+share/postgresql/extension/postgis_topology.control
+share/postgresql/extension/postgis_topology--2.0.0beta4--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha6--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha1--2.0.2.sql
+share/postgresql/extension/postgis_topology--unpackaged--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0beta2--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0beta1--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0rc1--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha2--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha3--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha4--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.1--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0rc2--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0alpha5--2.0.2.sql
+share/postgresql/extension/postgis_topology--2.0.0beta3--2.0.2.sql
+@dirrm share/postgresql/contrib/postgis-2.0
+@dirrmtry share/postgresql/contrib
+@dirrm share/postgis/tiger_2010/legacy_import/tiger2008
+@dirrm share/postgis/tiger_2010/geocode
+@dirrm share/postgis/tiger_2010/legacy_import
+@dirrm share/postgis/tiger_2010/normalize
+@dirrm share/postgis/tiger_2010/regress
+@dirrm share/postgis/tiger_2010/tables
+@dirrm share/postgis/tiger_2010/topology
+@dirrm share/postgis/tiger_2010/utility
+@dirrm share/postgis/tiger_2010
+@dirrm share/postgis/utils
+@dirrm share/postgis