aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-11 07:05:36 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-11 07:05:36 +0800
commitf83190d64d69406ee918b4e511db601e84ae6185 (patch)
treef2d1d49829935cc3fbd2b0b61397165765ae05d7 /databases
parent0ee7e45760187b5d171b51a3d27bbbbafbe3ab8e (diff)
downloadfreebsd-ports-gnome-f83190d64d69406ee918b4e511db601e84ae6185.tar.gz
freebsd-ports-gnome-f83190d64d69406ee918b4e511db601e84ae6185.tar.zst
freebsd-ports-gnome-f83190d64d69406ee918b4e511db601e84ae6185.zip
- OPTIONally support SSL
PR: ports/152230 Submitted by: Emanuel Haupt <ehaupt@freebsd.org> Approved by: maintainer timeout (skv ; 24 days)
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-DBD-mysql/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 98ec129fd45f..e183e620eab4 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -26,4 +26,13 @@ PERL_CONFIGURE= yes
MAN3= Bundle::DBD::mysql.3 DBD::mysql.3 DBD::mysql::INSTALL.3
+OPTIONS= SSL "build with OpenSSL support" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= --ssl
+RUN_DEPENDS+= p5-security/p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
+.endif
+
.include <bsd.port.mk>