aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-13 15:13:07 +0800
committeredwin <edwin@FreeBSD.org>2008-06-13 15:13:07 +0800
commit23707349ca275795805a09e5abdf32af10863ec8 (patch)
tree12b7a0f99dbbbac15e11431b25b83106415d7198 /databases
parent2e3da1e5dfab3d6b9ccc011bd218ae6f3c145f5b (diff)
downloadfreebsd-ports-gnome-23707349ca275795805a09e5abdf32af10863ec8.tar.gz
freebsd-ports-gnome-23707349ca275795805a09e5abdf32af10863ec8.tar.zst
freebsd-ports-gnome-23707349ca275795805a09e5abdf32af10863ec8.zip
[NEW PORTS] www/webobjects(+) Apple WebObjects ports bundle
This is a bundle of several ports covering many typical requirements for building an Apple WebObjects deployment environment. Each port is or has a dependancy with some other port in the bundle, and have therefore been lodged collectively. databases/openbase-jdbc: This is the official implementation of JDBC, the Java Database Connectivity API, for accessing OpenBase databases from Java. WWW: http://www.openbase.com/ PR: ports/117299 Submitted by: Quinton Dolan <q@onthenet.com.au>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/openbase-jdbc/Makefile40
-rw-r--r--databases/openbase-jdbc/distinfo3
-rw-r--r--databases/openbase-jdbc/files/pkg-message.in7
-rw-r--r--databases/openbase-jdbc/pkg-descr4
5 files changed, 55 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6ca567d41ceb..95ddd1628f4c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -188,6 +188,7 @@
SUBDIR += namazu2
SUBDIR += ocaml-pgocaml
SUBDIR += ocaml-sqlite3
+ SUBDIR += openbase-jdbc
SUBDIR += opendbx
SUBDIR += oracle7-client
SUBDIR += oracle8-client
diff --git a/databases/openbase-jdbc/Makefile b/databases/openbase-jdbc/Makefile
new file mode 100644
index 000000000000..f891110e3d6b
--- /dev/null
+++ b/databases/openbase-jdbc/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: openbase-jdbc
+# Date created: Mon Apr 16 07:07:22 EST 2007
+# Whom: Quinton Dolan <q@onthenet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openbase
+PORTVERSION= 2006.10
+CATEGORIES= databases java
+MASTER_SITES+= http://web.mac.com/openbase/download/interfaces/
+PKGNAMESUFFIX= -jdbc
+DISTNAME= OpenBaseJDBC_${OBVERSION}
+
+MAINTAINER?= q@onthenet.com.au
+COMMENT= The Java JDBC implementation for OpenBase
+
+USE_JAVA= yes
+USE_ZIP= yes
+JAVA_VERSION= 1.4+
+
+NO_BUILD= yes
+JARFILE= OpenBaseJDBC.jar
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+
+SUB_FILES+= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+OBVERSION= Oct2006
+WORK_SUBDIR= JDBC_10.09.2006
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${WORK_SUBDIR}/${JARFILE} ${JAVAJARDIR}/${JARFILE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/databases/openbase-jdbc/distinfo b/databases/openbase-jdbc/distinfo
new file mode 100644
index 000000000000..da49b7d2c379
--- /dev/null
+++ b/databases/openbase-jdbc/distinfo
@@ -0,0 +1,3 @@
+MD5 (OpenBaseJDBC_Oct2006.zip) = 9c0d240b1e8dcba38ba1eab1396ce7ae
+SHA256 (OpenBaseJDBC_Oct2006.zip) = 89fcf1a3b9b73cc5cd11bb7435d07eb2d204e956a4ca6a332ee1021e65a5be15
+SIZE (OpenBaseJDBC_Oct2006.zip) = 81512
diff --git a/databases/openbase-jdbc/files/pkg-message.in b/databases/openbase-jdbc/files/pkg-message.in
new file mode 100644
index 000000000000..abc1e6a12098
--- /dev/null
+++ b/databases/openbase-jdbc/files/pkg-message.in
@@ -0,0 +1,7 @@
+
+OpenBase JDBC support installed!
+
+OpenBaseJDBC.jar resides in
+%%JAVAJARDIR%%/OpenBaseJDBC.jar
+Add this to your CLASSPATH!
+
diff --git a/databases/openbase-jdbc/pkg-descr b/databases/openbase-jdbc/pkg-descr
new file mode 100644
index 000000000000..b1c8756b3662
--- /dev/null
+++ b/databases/openbase-jdbc/pkg-descr
@@ -0,0 +1,4 @@
+This is the official implementation of JDBC, the Java Database
+Connectivity API, for accessing OpenBase databases from Java.
+
+WWW: http://www.openbase.com/