aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-03 04:07:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-03 04:07:40 +0800
commit238da5b3993426f2d33b3e8909ecc845d4710969 (patch)
tree3c829371bd434de0bdcc1ac8b4f6be7a0f994fff /databases
parent4a29bc3131b9e52a9a99a5fc073c2827a0b40294 (diff)
downloadfreebsd-ports-gnome-238da5b3993426f2d33b3e8909ecc845d4710969.tar.gz
freebsd-ports-gnome-238da5b3993426f2d33b3e8909ecc845d4710969.tar.zst
freebsd-ports-gnome-238da5b3993426f2d33b3e8909ecc845d4710969.zip
- Unbreak postgresql-plpython: allow build with threaded python
- Pass maintainership to submitter PR: ports/159843 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-plpython/Makefile4
-rw-r--r--databases/postgresql82-server/files/patch-configure11
-rw-r--r--databases/postgresql83-server/files/patch-configure11
-rw-r--r--databases/postgresql84-server/files/patch-configure11
-rw-r--r--databases/postgresql90-server/files/patch-configure11
-rw-r--r--databases/postgresql90-server/pkg-plist-plpython1
-rw-r--r--databases/postgresql91-server/files/patch-configure11
-rw-r--r--databases/postgresql91-server/pkg-plist-plpython12
-rw-r--r--databases/postgresql92-server/files/patch-configure11
-rw-r--r--databases/postgresql92-server/pkg-plist-plpython12
10 files changed, 90 insertions, 5 deletions
diff --git a/databases/postgresql-plpython/Makefile b/databases/postgresql-plpython/Makefile
index 85b0cc01e818..3e110251368b 100644
--- a/databases/postgresql-plpython/Makefile
+++ b/databases/postgresql-plpython/Makefile
@@ -10,11 +10,9 @@ PORTREVISION= 1
CATEGORIES= databases python
PKGNAMESUFFIX= -plpython
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cvs-src@yandex.ru
COMMENT= A module for using Python to write SQL functions
-BROKEN= Does not configure without threaded Python
-
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
MASTERDIR= ${.CURDIR}/../postgresql${PGSQL_VER}-server
diff --git a/databases/postgresql82-server/files/patch-configure b/databases/postgresql82-server/files/patch-configure
new file mode 100644
index 000000000000..805576f6eef9
--- /dev/null
+++ b/databases/postgresql82-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-04-15 11:19:01.000000000 +0800
++++ configure 2011-09-12 15:51:28.020669918 +0800
+@@ -5077,7 +5077,7 @@
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql83-server/files/patch-configure b/databases/postgresql83-server/files/patch-configure
new file mode 100644
index 000000000000..724b6403b379
--- /dev/null
+++ b/databases/postgresql83-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-04-15 11:18:15.000000000 +0800
++++ configure 2011-09-12 15:51:07.149762023 +0800
+@@ -5458,7 +5458,7 @@
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql84-server/files/patch-configure b/databases/postgresql84-server/files/patch-configure
new file mode 100644
index 000000000000..ee9f1c3a38b1
--- /dev/null
+++ b/databases/postgresql84-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-04-15 11:17:14.000000000 +0800
++++ configure 2011-09-12 15:50:36.966309098 +0800
+@@ -6931,7 +6931,7 @@
+ { echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6; }
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql90-server/files/patch-configure b/databases/postgresql90-server/files/patch-configure
new file mode 100644
index 000000000000..3cffc1be44cc
--- /dev/null
+++ b/databases/postgresql90-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-04-15 11:15:53.000000000 +0800
++++ configure 2011-09-12 15:48:52.286638637 +0800
+@@ -7051,7 +7051,7 @@
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { $as_echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ $as_echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql90-server/pkg-plist-plpython b/databases/postgresql90-server/pkg-plist-plpython
index d3c29953b6b5..17473ec5331c 100644
--- a/databases/postgresql90-server/pkg-plist-plpython
+++ b/databases/postgresql90-server/pkg-plist-plpython
@@ -1,4 +1,5 @@
%%DOCSDIR%%/README-plpython
lib/postgresql/plpython.so
+lib/postgresql/plpython2.so
@dirrmtry lib/postgresql
@dirrmtry %%DOCSDIR%%
diff --git a/databases/postgresql91-server/files/patch-configure b/databases/postgresql91-server/files/patch-configure
new file mode 100644
index 000000000000..10cb1a3fed3f
--- /dev/null
+++ b/databases/postgresql91-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-07-08 08:12:33.000000000 +0800
++++ configure 2011-09-12 15:47:13.056511624 +0800
+@@ -7283,7 +7283,7 @@
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { $as_echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ $as_echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql91-server/pkg-plist-plpython b/databases/postgresql91-server/pkg-plist-plpython
index d3c29953b6b5..cfc34f4b56b9 100644
--- a/databases/postgresql91-server/pkg-plist-plpython
+++ b/databases/postgresql91-server/pkg-plist-plpython
@@ -1,4 +1,14 @@
%%DOCSDIR%%/README-plpython
-lib/postgresql/plpython.so
+lib/postgresql/plpython2.so
+%%DATADIR%%/extension/plpythonu.control
+%%DATADIR%%/extension/plpythonu--1.0.sql
+%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython2u.control
+%%DATADIR%%/extension/plpython2u--1.0.sql
+%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+@dirrmtry %%DATADIR%%/extension
@dirrmtry lib/postgresql
@dirrmtry %%DOCSDIR%%
diff --git a/databases/postgresql92-server/files/patch-configure b/databases/postgresql92-server/files/patch-configure
new file mode 100644
index 000000000000..10cb1a3fed3f
--- /dev/null
+++ b/databases/postgresql92-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-07-08 08:12:33.000000000 +0800
++++ configure 2011-09-12 15:47:13.056511624 +0800
+@@ -7283,7 +7283,7 @@
+ { $as_echo "$as_me:$LINENO: result: yes" >&5
+ $as_echo "yes" >&6; }
+ case $host_os in
+- openbsd*|freebsd*)
++ openbsd*)
+ { { $as_echo "$as_me:$LINENO: error: threaded Python not supported on this platform" >&5
+ $as_echo "$as_me: error: threaded Python not supported on this platform" >&2;}
+ { (exit 1); exit 1; }; }
diff --git a/databases/postgresql92-server/pkg-plist-plpython b/databases/postgresql92-server/pkg-plist-plpython
index d3c29953b6b5..cfc34f4b56b9 100644
--- a/databases/postgresql92-server/pkg-plist-plpython
+++ b/databases/postgresql92-server/pkg-plist-plpython
@@ -1,4 +1,14 @@
%%DOCSDIR%%/README-plpython
-lib/postgresql/plpython.so
+lib/postgresql/plpython2.so
+%%DATADIR%%/extension/plpythonu.control
+%%DATADIR%%/extension/plpythonu--1.0.sql
+%%DATADIR%%/extension/plpythonu--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython2u.control
+%%DATADIR%%/extension/plpython2u--1.0.sql
+%%DATADIR%%/extension/plpython2u--unpackaged--1.0.sql
+%%DATADIR%%/extension/plpython3u.control
+%%DATADIR%%/extension/plpython3u--1.0.sql
+%%DATADIR%%/extension/plpython3u--unpackaged--1.0.sql
+@dirrmtry %%DATADIR%%/extension
@dirrmtry lib/postgresql
@dirrmtry %%DOCSDIR%%