aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-11-02 05:25:50 +0800
committerantoine <antoine@FreeBSD.org>2015-11-02 05:25:50 +0800
commit23b4a8e4cf687a6cf6fd84287b364b149f48a47a (patch)
tree1836beb6c4f3fd0053b59ff86c8a3e7ad61f405e /databases
parent97f5ae1dcf35abb50b39ad9e632768650af7409e (diff)
downloadfreebsd-ports-gnome-23b4a8e4cf687a6cf6fd84287b364b149f48a47a.tar.gz
freebsd-ports-gnome-23b4a8e4cf687a6cf6fd84287b364b149f48a47a.tar.zst
freebsd-ports-gnome-23b4a8e4cf687a6cf6fd84287b364b149f48a47a.zip
Unbreak after the switch from USE_GCC=4.8+ to USE_GCC=yes
Reported by: pkg-fallout
Diffstat (limited to 'databases')
-rw-r--r--databases/tarantool/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 3d3d87b56b9a..cfa817688e74 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -47,14 +47,15 @@ PLIST_SUB+= TT_USER=${USERS} \
OPTIONS_DEFINE= DEBUG
DEBUG_DESC= Enable debug
-.if defined(USE_GCC) && ${USE_GCC:S/+//} == 4.8
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_trivia_config.h.cmake
-.endif
-
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+# XXX we rely on USES=perl5 to load bsd.default-versions.mk
+.if defined(USE_GCC) && ${USE_GCC} == yes && ${GCC_DEFAULT} == 4.8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_trivia_config.h.cmake
+.endif
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_BUILD_TYPE= RelWithDebugInfo
@@ -70,4 +71,4 @@ post-install:
${STAGEDIR}${TT_RUNDIR} \
${STAGEDIR}${ETCDIR}/instances.enabled
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>