aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-10-11 05:36:09 +0800
committerantoine <antoine@FreeBSD.org>2014-10-11 05:36:09 +0800
commit293ce54079b34ff988407f60d5c0a6015f1a985c (patch)
treed1340301777f6d8dac76edec1818c0f763647c84 /databases
parentf628b11f7e42c72af44a58e33875f9a7e41d6a19 (diff)
downloadfreebsd-ports-gnome-293ce54079b34ff988407f60d5c0a6015f1a985c.tar.gz
freebsd-ports-gnome-293ce54079b34ff988407f60d5c0a6015f1a985c.tar.zst
freebsd-ports-gnome-293ce54079b34ff988407f60d5c0a6015f1a985c.zip
- Allow staging as a regular user
- Bump portrevision as files were not packaged with intended group
Diffstat (limited to 'databases')
-rw-r--r--databases/mywwwatcher/Makefile3
-rw-r--r--databases/mywwwatcher/pkg-plist14
2 files changed, 10 insertions, 7 deletions
diff --git a/databases/mywwwatcher/Makefile b/databases/mywwwatcher/Makefile
index 65feeb325e86..6376d7c8f245 100644
--- a/databases/mywwwatcher/Makefile
+++ b/databases/mywwwatcher/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mywwwatcher
PORTVERSION= 3.2
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= http://www.the.cz/mywwwatcher/files/
DISTNAME= mywwwatcher-${PORTVERSION}
@@ -15,6 +16,7 @@ WRKSRC= ${WRKDIR}/mywwwatcher
WANT_PHP_WEB= yes
DEFAULT_PHP_VER= 5
USE_PHP= pcre session mysql
+PLIST_SUB= WWWGRP="${WWWGRP}"
NO_BUILD= yes
@@ -23,7 +25,6 @@ SUB_FILES= pkg-message
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
@${CP} -Rp ${WRKSRC}/* ${STAGEDIR}${WWWDIR}
- @${CHGRP} -R ${WWWGRP} ${STAGEDIR}${WWWDIR}
@${CHMOD} 775 ${STAGEDIR}${WWWDIR}/ini
@${CHMOD} 775 ${STAGEDIR}${WWWDIR}/query_archive
diff --git a/databases/mywwwatcher/pkg-plist b/databases/mywwwatcher/pkg-plist
index 6a9c42578daf..d16721259226 100644
--- a/databases/mywwwatcher/pkg-plist
+++ b/databases/mywwwatcher/pkg-plist
@@ -1,3 +1,4 @@
+@group %%WWWGRP%%
%%WWWDIR%%/README
%%WWWDIR%%/README.cz
%%WWWDIR%%/charset.php
@@ -32,9 +33,10 @@
%%WWWDIR%%/stat.php
%%WWWDIR%%/style.css
%%WWWDIR%%/top.php
-@dirrm %%WWWDIR%%/query_archive
-@dirrm %%WWWDIR%%/lang
-@dirrm %%WWWDIR%%/include
-@dirrm %%WWWDIR%%/ini
-@dirrm %%WWWDIR%%/graphics
-@dirrm %%WWWDIR%%
+@dir %%WWWDIR%%/query_archive
+@dir %%WWWDIR%%/lang
+@dir %%WWWDIR%%/include
+@dir %%WWWDIR%%/ini
+@dir %%WWWDIR%%/graphics
+@dir %%WWWDIR%%
+@group