aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-04-08 04:14:55 +0800
committermi <mi@FreeBSD.org>2015-04-08 04:14:55 +0800
commit35cbc54f84c53052b82f7da272e2bcca86c50e37 (patch)
treec7c8ff62038682290f3107019934364589925d1b /databases
parent4c4c14aa2d17f0f2aa6cbfcf45cdf6a4e0733c65 (diff)
downloadfreebsd-ports-gnome-35cbc54f84c53052b82f7da272e2bcca86c50e37.tar.gz
freebsd-ports-gnome-35cbc54f84c53052b82f7da272e2bcca86c50e37.tar.zst
freebsd-ports-gnome-35cbc54f84c53052b82f7da272e2bcca86c50e37.zip
Unbreak by asking php for sqlite3-extension offered by php-5.4 and
up, instead of sqlite. Upgrade from 1.2.3 to 1.2.4 released in 2010. Do not install the empty TODO-file. Be sure to convert DOS ends-of-line. Preserve time-stamps on files and directories, when installing. Define LICENSE.
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlitemanager/Makefile15
-rw-r--r--databases/sqlitemanager/distinfo4
-rw-r--r--databases/sqlitemanager/pkg-descr2
-rw-r--r--databases/sqlitemanager/pkg-plist8
4 files changed, 15 insertions, 14 deletions
diff --git a/databases/sqlitemanager/Makefile b/databases/sqlitemanager/Makefile
index e01c0a7394fe..a42c178e69b8 100644
--- a/databases/sqlitemanager/Makefile
+++ b/databases/sqlitemanager/Makefile
@@ -2,24 +2,25 @@
# $FreeBSD$
PORTNAME= sqlitemanager
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= databases www
MASTER_SITES= SF
-DISTNAME= SQLiteManager-${PORTVERSION}
+DISTNAME= SQliteManager-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multilingual web based tool to manage SQLite database
-DEPRECATED= requires php53, security EOL reached 14 Aug 2014
-EXPIRATION_DATE= 2015-04-15
+LICENSE= GPLv2
-IGNORE_WITH_PHP=5 55 56
+WRKSRC= ${WRKDIR}/SQLiteManager-${PORTVERSION}
+USES= dos2unix
NO_BUILD= yes
PLIST_SUB+= WWWDIR_REL="${WWWDIR_REL}"
-USE_PHP= sqlite
+USE_PHP= sqlite${PHP_VER:S/^53$$//:C/^.+$$/3/}
+EXTRACT_AFTER_ARGS=--exclude TODO
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
- ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
+ ${CP} -Rp ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
.include <bsd.port.mk>
diff --git a/databases/sqlitemanager/distinfo b/databases/sqlitemanager/distinfo
index a24609eff2c7..8c1a0f833cc0 100644
--- a/databases/sqlitemanager/distinfo
+++ b/databases/sqlitemanager/distinfo
@@ -1,2 +1,2 @@
-SHA256 (SQLiteManager-1.2.3.tar.gz) = 726d73d82a647a0dc23c0932d77082cf4e81235fe86fa9b04ed6c087e124b4eb
-SIZE (SQLiteManager-1.2.3.tar.gz) = 730876
+SHA256 (SQliteManager-1.2.4.tar.gz) = 831a186e781c2bc377c368f8dbcabca7661bcf16d679b5b3c69bec9ef65ac91b
+SIZE (SQliteManager-1.2.4.tar.gz) = 728181
diff --git a/databases/sqlitemanager/pkg-descr b/databases/sqlitemanager/pkg-descr
index 8fa8ee12abd9..5e75734c8229 100644
--- a/databases/sqlitemanager/pkg-descr
+++ b/databases/sqlitemanager/pkg-descr
@@ -2,4 +2,4 @@ SQLiteManager is a multilingual web based tool to manage SQLite
database. The programming language used is: PHP4, but work fine with
PHP5. Work just as well on a platform Linux as on Windows or MAC.
-WWW: http://www.sqlitemanager.org/
+WWW: http://www.sqlitemanager.org/
diff --git a/databases/sqlitemanager/pkg-plist b/databases/sqlitemanager/pkg-plist
index bdfc91aabeac..5bb5e872f858 100644
--- a/databases/sqlitemanager/pkg-plist
+++ b/databases/sqlitemanager/pkg-plist
@@ -1,7 +1,7 @@
%%WWWDIR_REL%%/CHANGES
%%WWWDIR_REL%%/INSTALL
-%%WWWDIR_REL%%/LICENCE
-%%WWWDIR_REL%%/TODO
+%%WWWDIR_REL%%/LICENSE
+@comment %%WWWDIR_REL%%/TODO
%%WWWDIR_REL%%/favicon.ico
%%WWWDIR_REL%%/include/JSCookMenu.js
%%WWWDIR_REL%%/include/ParsingQuery.class.php
@@ -34,9 +34,9 @@
%%WWWDIR_REL%%/include/sql.class.php
%%WWWDIR_REL%%/include/sql.php
%%WWWDIR_REL%%/include/sqlite.class.php
-%%WWWDIR_REL%%/include/sqlite2.class.php
+%%WWWDIR_REL%%/include/sqlite_2.class.php
%%WWWDIR_REL%%/include/sqlite2.inc.php
-%%WWWDIR_REL%%/include/sqlite3.class.php
+%%WWWDIR_REL%%/include/sqlite_3.class.php
%%WWWDIR_REL%%/include/sqlite3.inc.php
%%WWWDIR_REL%%/include/sqlite_fulltextsearch.class.php
%%WWWDIR_REL%%/include/sqlite_fulltextsearchex.class.php