aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2018-10-19 06:15:25 +0800
committerosa <osa@FreeBSD.org>2018-10-19 06:15:25 +0800
commit3bd4bd17735b974cdf01895d96429de6b0bec068 (patch)
treebfe9607ff57c9d629aaba542b78b5f710c96aecd /databases
parent473dafba831e8d0aeecbe4856b7c2330937bb9e9 (diff)
downloadfreebsd-ports-gnome-3bd4bd17735b974cdf01895d96429de6b0bec068.tar.gz
freebsd-ports-gnome-3bd4bd17735b974cdf01895d96429de6b0bec068.tar.zst
freebsd-ports-gnome-3bd4bd17735b974cdf01895d96429de6b0bec068.zip
Upgrade from 5.0-rc5 to 5.0.0.
<ChangeLog> Upgrade urgency CRITICAL: Several fixes to streams AOF and replication. Hi all and welcome to the first stable release of Redis 5! \o/ To start a quick recap of what's new in Redis 5: 1. The new Stream data type. https://redis.io/topics/streams-intro 2. New Redis modules APIs: Timers, Cluster and Dictionary APIs. 3. RDB now store LFU and LRU information. 4. The cluster manager was ported from Ruby (redis-trib.rb) to C code inside redis-cli. Check `redis-cli --cluster help` for more info. 5. New sorted set commands: ZPOPMIN/MAX and blocking variants. 6. Active defragmentation version 2. 7. Improvemenets in HyperLogLog implementations. 8. Better memory reporting capabilities. 9. Many commands with sub-commands now have an HELP subcommand. 10. Better performances when clients connect and disconnect often. 11. Many bug fixes and other random improvements. 12. Jemalloc was upgraded to version 5.1 13. CLIENT UNBLOCK and CLIENT ID. 14. The LOLWUT command was added. http://antirez.com/news/123 15. We no longer use the "slave" word if not for API backward compatibility. 16. Differnet optimizations in the networking layer. 17. Lua improvements: - Better propagation of Lua scripts to slaves / AOF. - Lua scripts can now timeout and get in -BUSY state in the slave as well. 18. Dynamic HZ to balance idle CPU usage with responsiveness. 19. The Redis core was refactored and improved in many ways. </ChangeLog>
Diffstat (limited to 'databases')
-rw-r--r--databases/redis-devel/Makefile6
-rw-r--r--databases/redis-devel/distinfo6
-rw-r--r--databases/redis-devel/files/extra-patch-src-Makefile.lua10
-rw-r--r--databases/redis-devel/files/extra-patch-src-Makefile.luajit10
4 files changed, 15 insertions, 17 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 8cc900dd79f5..40fcd86221be 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 5.0-rc5
+DISTVERSION= 5.0.0
CATEGORIES= databases
+MASTER_SITES= http://download.redis.io/releases/
PKGNAMESUFFIX= -devel
MAINTAINER= osa@FreeBSD.org
@@ -11,9 +12,6 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-USE_GITHUB= yes
-GH_ACCOUNT= antirez
-
OPTIONS_DEFINE= JEMALLOC TESTS TRIB
OPTIONS_RADIO= EXTLUA
OPTIONS_RADIO_EXTLUA= LUA LUAJIT
diff --git a/databases/redis-devel/distinfo b/databases/redis-devel/distinfo
index 9d5498dee2f0..68edf3b4ee77 100644
--- a/databases/redis-devel/distinfo
+++ b/databases/redis-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536357782
-SHA256 (antirez-redis-5.0-rc5_GH0.tar.gz) = d070c8a3514e40da5cef9ec26dfd594df0468c203c36398ef2d359a32502b548
-SIZE (antirez-redis-5.0-rc5_GH0.tar.gz) = 1941761
+TIMESTAMP = 1539880826
+SHA256 (redis-5.0.0.tar.gz) = 70c98b2d0640b2b73c9d8adb4df63bcb62bad34b788fe46d1634b6cf87dc99a4
+SIZE (redis-5.0.0.tar.gz) = 1947721
diff --git a/databases/redis-devel/files/extra-patch-src-Makefile.lua b/databases/redis-devel/files/extra-patch-src-Makefile.lua
index 06cf41e05e17..17c3d23b74b5 100644
--- a/databases/redis-devel/files/extra-patch-src-Makefile.lua
+++ b/databases/redis-devel/files/extra-patch-src-Makefile.lua
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2017-08-06 10:42:53.992510000 -0400
-+++ src/Makefile 2017-08-06 10:44:57.344366000 -0400
+--- src/Makefile.orig 2018-10-18 18:09:43.930566000 -0400
++++ src/Makefile 2018-10-18 18:10:32.562125000 -0400
@@ -16,7 +16,7 @@
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
@@ -30,7 +30,7 @@
ifeq ($(MALLOC),tcmalloc)
FINAL_CFLAGS+= -DUSE_TCMALLOC
@@ -130,6 +130,9 @@
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a
+ FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
endif
+FINAL_CFLAGS+=-I${PREFIX}/include/lua51
@@ -42,10 +42,10 @@
@@ -150,6 +153,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o lolwut.o lolwut5.o
+REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
+ REDIS_CLI_OBJ=anet.o adlist.o dict.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o siphash.o crc16.o
REDIS_BENCHMARK_NAME=redis-benchmark
@@ -201,7 +205,7 @@
diff --git a/databases/redis-devel/files/extra-patch-src-Makefile.luajit b/databases/redis-devel/files/extra-patch-src-Makefile.luajit
index 2966fb48ea8b..a0cc15f0f22a 100644
--- a/databases/redis-devel/files/extra-patch-src-Makefile.luajit
+++ b/databases/redis-devel/files/extra-patch-src-Makefile.luajit
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2017-08-06 10:48:29.559222000 -0400
-+++ src/Makefile 2017-08-06 10:50:45.155432000 -0400
+--- src/Makefile.orig 2018-10-18 18:11:24.649811000 -0400
++++ src/Makefile 2018-10-18 18:11:35.160523000 -0400
@@ -16,7 +16,7 @@
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
@@ -30,7 +30,7 @@
ifeq ($(MALLOC),tcmalloc)
FINAL_CFLAGS+= -DUSE_TCMALLOC
@@ -130,6 +130,9 @@
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a
+ FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
endif
+FINAL_CFLAGS+=-I${PREFIX}/include/luajit-2.0
@@ -42,10 +42,10 @@
@@ -150,6 +153,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o lolwut.o lolwut5.o
+REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
+ REDIS_CLI_OBJ=anet.o adlist.o dict.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o siphash.o crc16.o
REDIS_BENCHMARK_NAME=redis-benchmark
@@ -201,7 +205,7 @@