aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-12-10 03:24:52 +0800
committerale <ale@FreeBSD.org>2005-12-10 03:24:52 +0800
commit41604a0f0d82280948cab0ad263522cd6969d6f1 (patch)
treec92d5ad743f770a008b8555c05f3f1723eb36467 /databases
parentc77ed4f552b975e069cc5960a2a5c8c8c76a6f54 (diff)
downloadfreebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.tar.gz
freebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.tar.zst
freebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.zip
Remove pear ports obsolated by devel/pear and switch
dependencies of all the other pear ports. Discussed with: thierry, antonio@php.net
Diffstat (limited to 'databases')
-rw-r--r--databases/pear-DB/Makefile4
-rw-r--r--databases/pear-DBA/Makefile4
-rw-r--r--databases/pear-DB_DataObject/Makefile2
-rw-r--r--databases/pear-DB_DataObject_FormBuilder/Makefile2
-rw-r--r--databases/pear-DB_Pager/Makefile4
-rw-r--r--databases/pear-DB_QueryTool/Makefile2
-rw-r--r--databases/pear-DB_Table/Makefile2
-rw-r--r--databases/pear-DB_ldap/Makefile2
-rw-r--r--databases/pear-DB_ldap2/Makefile2
-rw-r--r--databases/pear-MDB/Makefile2
-rw-r--r--databases/pear-MDB2/Makefile2
-rw-r--r--databases/pear-MDB_QueryTool/Makefile2
12 files changed, 15 insertions, 15 deletions
diff --git a/databases/pear-DB/Makefile b/databases/pear-DB/Makefile
index 0653dd256f11..2ca5238aa132 100644
--- a/databases/pear-DB/Makefile
+++ b/databases/pear-DB/Makefile
@@ -13,7 +13,7 @@ CATEGORIES= databases www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR Database Abstraction Layer
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_REINPLACE= yes
@@ -40,7 +40,7 @@ TESTS= db_error.phpt db_parsedsn.phpt db_factory.phpt db_ismanip.phpt \
_DOCSDIR= doc
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
post-patch:
.for file in ${FILES}
diff --git a/databases/pear-DBA/Makefile b/databases/pear-DBA/Makefile
index 0d201d0757cb..70c18ca63d14 100644
--- a/databases/pear-DBA/Makefile
+++ b/databases/pear-DBA/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= databases www pear
MAINTAINER= antonio@php.net
COMMENT= Berkely-style database abstraction class
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
FILES= DBA.php DBA/Compatibility.php DBA/Driver/File.php DBA/Driver/Builtin.php
@@ -20,5 +20,5 @@ TESTS= benchmark_drivers.php test_drivers.php test_compatibility.php
DOCS= README.txt
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_DataObject/Makefile b/databases/pear-DB_DataObject/Makefile
index 519420ce4625..11a8d358851b 100644
--- a/databases/pear-DB_DataObject/Makefile
+++ b/databases/pear-DB_DataObject/Makefile
@@ -36,5 +36,5 @@ post-patch:
RUN_DEPENDS+= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
.endif
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_DataObject_FormBuilder/Makefile b/databases/pear-DB_DataObject_FormBuilder/Makefile
index 8d1852bffb45..614015a719ec 100644
--- a/databases/pear-DB_DataObject_FormBuilder/Makefile
+++ b/databases/pear-DB_DataObject_FormBuilder/Makefile
@@ -36,5 +36,5 @@ RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date
RUN_DEPENDS+= ${PEARDIR}/HTML/Table.php:${PORTSDIR}/devel/pear-HTML_Table
.endif
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_Pager/Makefile b/databases/pear-DB_Pager/Makefile
index ed573b7b8a44..731515181751 100644
--- a/databases/pear-DB_Pager/Makefile
+++ b/databases/pear-DB_Pager/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= toshiya@saitoh.nu
COMMENT= PEAR Database Abstraction Layer
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR \
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -21,5 +21,5 @@ NO_BUILD= yes
FILES= Pager.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_QueryTool/Makefile b/databases/pear-DB_QueryTool/Makefile
index f352e5912fe5..7262dfc6038d 100644
--- a/databases/pear-DB_QueryTool/Makefile
+++ b/databases/pear-DB_QueryTool/Makefile
@@ -39,5 +39,5 @@ TESTS= Common.php Get.php GetAll.php GetCount.php GetQueryString.php index.php
_EXAMPLESDIR= docs/examples
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_Table/Makefile b/databases/pear-DB_Table/Makefile
index ef51c715ce0d..60a9ec0fc315 100644
--- a/databases/pear-DB_Table/Makefile
+++ b/databases/pear-DB_Table/Makefile
@@ -40,5 +40,5 @@ post-extract:
RUN_DEPENDS+= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm
.endif
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_ldap/Makefile b/databases/pear-DB_ldap/Makefile
index f5d97cd983ce..7d67c5b247d0 100644
--- a/databases/pear-DB_ldap/Makefile
+++ b/databases/pear-DB_ldap/Makefile
@@ -19,5 +19,5 @@ CATEGORY= DB
FILES= ldap.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_ldap2/Makefile b/databases/pear-DB_ldap2/Makefile
index f5d97cd983ce..7d67c5b247d0 100644
--- a/databases/pear-DB_ldap2/Makefile
+++ b/databases/pear-DB_ldap2/Makefile
@@ -19,5 +19,5 @@ CATEGORY= DB
FILES= ldap.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-MDB/Makefile b/databases/pear-MDB/Makefile
index 204c298e0df0..407f01286b53 100644
--- a/databases/pear-MDB/Makefile
+++ b/databases/pear-MDB/Makefile
@@ -44,5 +44,5 @@ _DOCSDIR= .
_TESTDIR= tests
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-MDB2/Makefile b/databases/pear-MDB2/Makefile
index 3285329ccc5c..5b79666ee53f 100644
--- a/databases/pear-MDB2/Makefile
+++ b/databases/pear-MDB2/Makefile
@@ -57,5 +57,5 @@ TESTS= clitest.php Console_TestListener.php driver_test.schema \
_EXAMPLESDIR= docs/examples
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/databases/pear-MDB_QueryTool/Makefile b/databases/pear-MDB_QueryTool/Makefile
index e0e6fb667e3d..2ee2bbe20ab6 100644
--- a/databases/pear-MDB_QueryTool/Makefile
+++ b/databases/pear-MDB_QueryTool/Makefile
@@ -39,5 +39,5 @@ TESTS= Common.php index.php Get.php GetAll.php GetCount.php GetQueryString.php
_EXAMPLESDIR= docs/examples
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>